Closed Bug 1222238 Opened 6 years ago Closed 6 years ago

Hang in preferences pane on OS X

Categories

(Instantbird :: Preferences, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Instantbird 45

People

(Reporter: arlolra, Assigned: aleth)

References

Details

(Keywords: regression, Whiteboard: [1.6-blocking])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/45.0.2454.85 Safari/537.36

Steps to reproduce:

Open prefs.
Click the Themes tab.
Click Advanced tab.
Open Network > Settings.


Actual results:

Hangs.


Expected results:

Not hangs.
This was introduced in Bug 1179943, the +1 there seems to be the cause.
Blocks: 1179943
Keywords: regression
Whiteboard: [1.6-blocking]
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: nobody → aleth
Status: NEW → ASSIGNED
Should you update viewlog.js with that as well?
Comment on attachment 8684473 [details] [diff] [review]
Avoid hang in proxy preferences pane

Review of attachment 8684473 [details] [diff] [review]:
-----------------------------------------------------------------

The hang seems to happen due to the getPendingMessages override (it goes away if the override is deleted after all the messages have been displayed). No idea what exactly causes the hang though.

This patch is a very slightly less hacky fix for bug 1179943 that avoids the problem.

Please check if this fixes it for you too (along with the original bug).
Attachment #8684473 - Flags: feedback?(arlolra)
(In reply to arlolra from comment #3)
> Should you update viewlog.js with that as well?

The code there isn't the same. So unless you can produce a hang there too somehow, I don't think we should worry...
Comment on attachment 8684473 [details] [diff] [review]
Avoid hang in proxy preferences pane

Review of attachment 8684473 [details] [diff] [review]:
-----------------------------------------------------------------

Yup, fixes the original bug and doesn't hang. Thanks!
Attachment #8684473 - Flags: feedback?(arlolra) → feedback+
Attachment #8684473 - Flags: review?(clokep)
Attachment #8684473 - Flags: review?(clokep) → review+
https://hg.mozilla.org/comm-central/rev/25266a5c96bfaffb7084a36c91e3002c4f233309
Bug 1222238 - Avoid hang in proxy preferences pane. r=clokep a=aleth
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Instantbird 45
You need to log in before you can comment on or make changes to this bug.