Unexpected error in MarionetteTestCase.tearDown in test_browser_share_link.py

RESOLVED WONTFIX

Status

Firefox OS
Gaia::UI Tests
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: Martijn Wargers (dead), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8629524 [details]
(PNG Image, 480 × 854 pixels) - Scaled (79%).png

I saw this in http://jenkins1.qa.scl3.mozilla.com/view/Bitbar/job/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2.bitbar/137/HTML_Report/
Traceback (most recent call last):
File "/var/lib/jenkins/jobs/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_client-0.16-py2.7.egg/marionette/marionette_test.py", line 326, in run
self.tearDown()
File "/var/lib/jenkins/jobs/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2.bitbar/workspace/tests/python/gaia-ui-tests/gaiatest/gaia_test.py", line 1151, in tearDown
MarionetteTestCase.tearDown(self)
File "/var/lib/jenkins/jobs/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_client-0.16-py2.7.egg/marionette/marionette_test.py", line 683, in tearDown
(self.filepath.replace('\\', '\\\\'), self.methodName))
File "/var/lib/jenkins/jobs/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_driver-0.9-py2.7.egg/marionette_driver/marionette.py", line 1509, in execute_script
filename=os.path.basename(frame[0]))
File "/var/lib/jenkins/jobs/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_driver-0.9-py2.7.egg/marionette_driver/decorators.py", line 36, in _
return func(*args, **kwargs)
File "/var/lib/jenkins/jobs/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_driver-0.9-py2.7.egg/marionette_driver/marionette.py", line 715, in _send_message
    self._handle_error(response)
  File "/var/lib/jenkins/jobs/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_driver-0.9-py2.7.egg/marionette_driver/marionette.py", line 751, in _handle_error
    raise errors.lookup(status)(message, stacktrace=stacktrace)
NoSuchWindowException: NoSuchWindowException: None

The screenshot is showing a homescreen without icons, so I suspect some lmk (low memory killing) might be going on here.
The test is: 
http://mxr.mozilla.org/gaia/source/tests/python/gaia-ui-tests/gaiatest/tests/functional/browser/test_browser_share_link.py

http://mxr.mozilla.org/gaia/source/tests/python/gaia-ui-tests/gaiatest/gaia_test.py#1146
http://mxr.mozilla.org/mozilla-central/source/testing/marionette/client/marionette/marionette_test.py#678

It seems to me that the tearDown is happening in a window that has been lmk-ed.
So perhaps by switching to the system frame (which should never be lmk-ed), we can prevent this situation?
(Reporter)

Comment 1

3 years ago
Created attachment 8629526 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/30824

So like this? Or perhaps I'm totally wrong about the cause here.
Dave Hunt is on vacation till 7/15, I can't ask review from him, although I would prefer that here.
Attachment #8629526 - Flags: review?(jlorenzo)
Attachment #8629526 - Flags: review?(jgriffin)
Comment on attachment 8629526 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/30824

That looks like a good idea. Can we run an adhoc job on the whole suite, to make sure we won't break anything with this change ?
Attachment #8629526 - Flags: review?(jlorenzo)
Comment on attachment 8629526 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/30824

I agree with your diagnosis; this _should_ do the trick.
Attachment #8629526 - Flags: review?(jgriffin) → review+
(Reporter)

Comment 4

3 years ago
(In reply to Johan Lorenzo [:jlorenzo] (QA) from comment #2)
> Comment on attachment 8629526 [details] [review]
> https://github.com/mozilla-b2g/gaia/pull/30824
> 
> That looks like a good idea. Can we run an adhoc job on the whole suite, to
> make sure we won't break anything with this change ?

I kicked of an adhoc job here: http://jenkins1.qa.scl3.mozilla.com/job/flame-kk.ui.adhoc.bitbar/120/
(Reporter)

Comment 5

3 years ago
Now correct (hopefully): http://jenkins1.qa.scl3.mozilla.com/job/flame-kk.ui.adhoc.bitbar/121/
(Reporter)

Comment 6

3 years ago
Unfortunately the previous Jenkins try run didn't complete. After a while, the connection to the device was lost.
This is a new Jenkins try run: http://jenkins1.qa.scl3.mozilla.com/job/flame-kk.ui.adhoc.bitbar/123/
(Reporter)

Comment 7

3 years ago
(In reply to Martijn Wargers [:mwargers] (QA) from comment #6)
> Unfortunately the previous Jenkins try run didn't complete. After a while,
> the connection to the device was lost.
> This is a new Jenkins try run:
> http://jenkins1.qa.scl3.mozilla.com/job/flame-kk.ui.adhoc.bitbar/123/

Again, the connection to the device was lost after a while. I don't think it has anything to do with the pull request, I think it happens because of running all the tests in 1 big loop. Is it ok to check this in?
Flags: needinfo?(jlorenzo)
(Reporter)

Comment 8

3 years ago
New test run, now only for smoketest: http://jenkins1.qa.scl3.mozilla.com/view/Bitbar/job/flame-kk.ui.adhoc.bitbar/129/
(Reporter)

Comment 9

3 years ago
(In reply to Martijn Wargers [:mwargers] (QA) from comment #8)
> New test run, now only for smoketest:
> http://jenkins1.qa.scl3.mozilla.com/view/Bitbar/job/flame-kk.ui.adhoc.bitbar/
> 129/

The Jenkins run all right, so I merged: https://github.com/mozilla-b2g/gaia/commit/6e68c718c1173fd97e912c51000a4223056d36e6
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Sorry for the delay. Thanks for the smoketest run.
Flags: needinfo?(jlorenzo)
(Reporter)

Comment 11

2 years ago
Unfortunately, it doesn't seem to have worked, I see this happening again in:
http://jenkins1.qa.scl3.mozilla.com/view/Bitbar/job/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.1.bitbar/207/HTML_Report/
UNEXPECTED_ERROR 	test_browser_share_link.py TestBrowserShareToMessages.test_browser_share_to_messages
Traceback (most recent call last):
File "/var/lib/jenkins/jobs/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.1.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_client-0.16-py2.7.egg/marionette/marionette_test.py", line 326, in run
self.tearDown()
File "/var/lib/jenkins/jobs/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.1.bitbar/workspace/tests/python/gaia-ui-tests/gaiatest/gaia_test.py", line 1140, in tearDown
self.marionette.switch_to_frame()
File "/var/lib/jenkins/jobs/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.1.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_driver-0.9-py2.7.egg/marionette_driver/marionette.py", line 1283, in switch_to_frame
return self._send_message("switchToFrame", "ok", **kwargs)
File "/var/lib/jenkins/jobs/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.1.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_driver-0.9-py2.7.egg/marionette_driver/decorators.py", line 36, in _
return func(*args, **kwargs)
File "/var/lib/jenkins/jobs/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.1.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_driver-0.9-py2.7.egg/marionette_driver/marionette.py", line 715, in _send_message
    self._handle_error(response)
  File "/var/lib/jenkins/jobs/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.1.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_driver-0.9-py2.7.egg/marionette_driver/marionette.py", line 751, in _handle_error
    raise errors.lookup(status)(message, stacktrace=stacktrace)
NoSuchWindowException: NoSuchWindowException: None

This is in the same run as when bug 1172343 is showing (which I now filed bug 1190791 for).

I guess the system app is somehow killed? Perhaps a logcat would have been useful here.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 12

2 years ago
And there is also bug 1189262 open, currently, which might be related to this.
(Reporter)

Updated

2 years ago
Assignee: martijn.martijn → nobody
(Reporter)

Comment 13

2 years ago
Marking WONTFIX, sorry for the bug spam. If somebody still wants to work on this, please file a new bug for it.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.