Cannot find wrl.h : No such file or directory when building WindowsUIUtils.obj

RESOLVED FIXED in Thunderbird 42.0

Status

MailNews Core
Build Config
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: ewong, Assigned: ewong)

Tracking

({dogfood})

Trunk
Thunderbird 42.0
x86_64
Windows Server 2008
dogfood

Thunderbird Tracking Flags

(thunderbird40 fixed, thunderbird41 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

2 years ago
while building Win32 trunk nightly, came across this bustage:

c:/builds/slave3/c-c/build/objdir/_virtualenv/Scripts/python.exe -m mozbuild.action.cl  cl -FonsTextStore.obj -c -I../../dist/stl_wrappers  -DWIN32_LEAN_AND_MEAN -D_WIN32 -DWIN32 -D_CRT_RAND_S -DCERT_CHAIN_PARA_HAS_EXTRA_FIELDS -DOS_WIN=1 -D_UNICODE -DCHROMIUM_BUILD -DU_STATIC_IMPLEMENTATION -DUNICODE -DNOMINMAX -D_WINDOWS -D_SECURE_ATL -DCOMPILER_MSVC -DMOZ_UNICODE -DSTATIC_EXPORTABLE_JS_API -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -DAB_CD=en-US -DNO_NSPR_10_SUPPORT -Ic:/builds/slave4/c-c/build/mozilla/widget/windows -I. -Ic:/builds/slave3/c-c/build/objdir/ipc/ipdl/_ipdlheaders -Ic:/builds/slave4/c-c/build/mozilla/ipc/chromium/src -Ic:/builds/slave4/c-c/build/mozilla/ipc/glue -Ic:/builds/slave4/c-c/build/mozilla/layout/generic -Ic:/builds/slave4/c-c/build/mozilla/layout/xul -Ic:/builds/slave4/c-c/build/mozilla/toolkit/xre -Ic:/builds/slave4/c-c/build/mozilla/widget -Ic:/builds/slave4/c-c/build/mozilla/xpcom/base -I../../dist/include   -Ic:/builds/slave3/c-c/build/objdir/dist/include/nspr -Ic:/builds/slave3/c-c/build/objdir/dist/include/nss        -MD            -FI ../../dist/include/mozilla-config.h -DMOZILLA_CLIENT  -TP -nologo -D_HAS_EXCEPTIONS=0 -W3 -Gy -arch:IA32 -FS -wd4251 -wd4244 -wd4267 -wd4345 -wd4351 -wd4482 -wd4800 -wd4819 -we4553 -GR-  -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -O1 -Oi -Oy-  -Ic:/builds/slave3/c-c/build/objdir/dist/include/cairo -Fdgenerated.pdb   c:/builds/slave4/c-c/build/mozilla/widget/windows/nsTextStore.cpp
nsWidgetFactory.obj
WindowsUIUtils.cpp
c:\builds\slave4\c-c\build\mozilla\widget\windows\mozwrlbase.h(77) : fatal error C1083: Cannot open include file: 'wrl.h': No such file or directory
c:/builds/slave4/c-c/build/mozilla/config/rules.mk:957: recipe for target 'WindowsUIUtils.obj' failed
mozmake.exe[4]: *** [WindowsUIUtils.obj] Error 2
mozmake.exe[4]: *** Waiting for unfinished jobs....
mozmake.exe[4]: Entering directory 'c:/builds/slave3/c-c/build/objdir/gfx/layers'
(Assignee)

Updated

2 years ago
OS: Unspecified → Windows Server 2008
Hardware: Unspecified → x86_64
(Assignee)

Comment 1

2 years ago
This WindowsUIUtils.cpp file was added in http://hg.mozilla.org/mozilla-central/rev/43873ca11c57.

Gijs, what libraries are required to build this?
Component: Build Config → Build Config
Product: SeaMonkey → MailNews Core
(Assignee)

Updated

2 years ago
Flags: needinfo?(gijskruitbosch+bugs)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 5

2 years ago
Actually.. I believe I know where the problem lies. Mailnews Core isn't including
the 8.1 winrt include directory in the mozconfig.vs2013-win64.
(Assignee)

Comment 6

2 years ago
Created attachment 8629550 [details] [diff] [review]
proposed patch(v1)
Assignee: nobody → ewong
Status: NEW → ASSIGNED
Attachment #8629550 - Flags: review?(Pidgeot18)
(Assignee)

Comment 7

2 years ago
Testing that patch on try-comm-central, and locally.
(Assignee)

Comment 8

2 years ago
Created attachment 8629585 [details] [diff] [review]
fixed proposed patch (v2)
Attachment #8629550 - Attachment is obsolete: true
Attachment #8629550 - Flags: review?(Pidgeot18)
Attachment #8629585 - Flags: review?(Pidgeot18)
(Assignee)

Comment 9

2 years ago
(In reply to Edmund Wong (:ewong) from comment #8)
> Created attachment 8629585 [details] [diff] [review]
> fixed proposed patch (v2)

https://hg.mozilla.org/try-comm-central/rev/4ca0597c5eea
Flags: needinfo?(gijskruitbosch+bugs)

Comment 10

2 years ago
This is the corresponding build error from the Linux and Mac builders:
> TEST-INFO | check-sync-dirs.py | file(s) found in: /builds/slave/tb-c-cen-lx-ntly-0000000000000/build/build
> TEST-INFO | check-sync-dirs.py | differ from their originals in: /builds/slave/tb-c-cen-lx-ntly-0000000000000/build/mozilla/build 
> TEST-INFO | check-sync-dirs.py | differing file: ./win64/mozconfig.vs2013
> TEST-INFO | check-sync-dirs.py | differing file: ./win32/mozconfig.vs2013-win64

Updated

2 years ago
Keywords: dogfood

Comment 11

2 years ago
Comment on attachment 8629585 [details] [diff] [review]
fixed proposed patch (v2)

Review of attachment 8629585 [details] [diff] [review]:
-----------------------------------------------------------------

Stealing this copy-paste review.
Attachment #8629585 - Flags: review?(Pidgeot18) → review+

Comment 12

2 years ago
https://hg.mozilla.org/comm-central/rev/f3ca0106f77c -> FIXED

Thx Edmund!
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox42: affected → ---
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 42.0

Comment 13

2 years ago
Late to this particular party, but it seems like this part of the mozconfig stuff should just be reused from m-c. That would avoid this kind of breakage in future.

Updated

2 years ago
Duplicate of this bug: 1186359

Updated

2 years ago
status-thunderbird40: --- → affected
status-thunderbird41: --- → affected

Comment 15

2 years ago
Comment on attachment 8629585 [details] [diff] [review]
fixed proposed patch (v2)

[Approval Request Comment]
Regression caused by (bug #): Bug 1170522 was uplifted to mozilla-aurora and mozilla-aurora, see Bug 1170522 Comment 49 and Bug 1170522 Comment 50.
User impact if declined: Build error Windows platform, no nightly builds available for testing.
Testing completed (on c-c, etc.): 
Risk to taking this patch (and alternatives if risky):
Attachment #8629585 - Flags: approval-comm-beta?
Attachment #8629585 - Flags: approval-comm-aurora?

Updated

2 years ago
Depends on: 1170522
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Updated

2 years ago
Attachment #8629585 - Flags: approval-comm-beta?
Attachment #8629585 - Flags: approval-comm-beta+
Attachment #8629585 - Flags: approval-comm-aurora?
Attachment #8629585 - Flags: approval-comm-aurora+
https://hg.mozilla.org/releases/comm-beta/rev/fc9b574f3f85
https://hg.mozilla.org/releases/comm-aurora/rev/c5db5a77faed

Comment 35

2 years ago
Thank you very much, comm-aurora and comm-beta builds are building again and are green.
status-thunderbird40: affected → fixed
status-thunderbird41: affected → fixed
You need to log in before you can comment on or make changes to this bug.