The default bug view has changed. See this FAQ.

Can't compose a message to a newsgroup from the header

RESOLVED FIXED in Thunderbird 43.0

Status

Thunderbird
Message Reader UI
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: squib, Assigned: squib)

Tracking

({regression})

38 Branch
Thunderbird 43.0
regression

Thunderbird Tracking Flags

(thunderbird40 wontfix, thunderbird41 fixed, thunderbird42 fixed, thunderbird43 fixed, thunderbird_esr3841+ fixed)

Details

(Whiteboard: [regression:TB38,TB39,TB40,TB41])

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
Created attachment 8629551 [details] [diff] [review]
Fix it

Normally, in the message header, you can click a newsgroup name and select "Compose Message To" to open a new compose window. This is currently broken (on nightly and 38.0). Here's a patch.

:rkent, I'm putting you down for review because you're the one who regressed it. :)
Attachment #8629551 - Flags: review?(rkent)
(Assignee)

Comment 1

2 years ago
Actually, maybe it was JorgK who broke it, but you're assigned to the bug. Oh well.

Updated

2 years ago
Keywords: regression

Comment 2

2 years ago
Comment on attachment 8629551 [details] [diff] [review]
Fix it

Let's let Magnus deal with this.
Attachment #8629551 - Flags: review?(rkent) → review?(mkmelin+mozilla)
Whiteboard: [regression:TB38,TB39,TB40,TB41]
Version: unspecified → 38

Comment 3

2 years ago
Comment on attachment 8629551 [details] [diff] [review]
Fix it

Review of attachment 8629551 [details] [diff] [review]:
-----------------------------------------------------------------

Sorry for the delay, LGTM! r=mkmelin
Attachment #8629551 - Flags: review?(mkmelin+mozilla) → review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed

Comment 4

2 years ago
https://hg.mozilla.org/comm-central/rev/4265dff7d59960c5d7a274cfbf025667127a6bb9
Bug 1180360 - "Can't compose a message to a newsgroup from the header". r=mkmelin

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 43.0

Comment 5

2 years ago
Does this require uplift?

Updated

2 years ago
Flags: needinfo?(squibblyflabbetydoo)

Comment 6

2 years ago
(In reply to Jim Porter (:squib) from comment #1)
> Actually, maybe it was JorgK who broke it, but you're assigned to the bug.
> Oh well.

Actually, Kent "improved" it, but I was shuffling/merging some patches on that bug, so it looks like it was me ;-) However, Kent did a great job back then, that was an absolutely urgent fix he landed. The person who really broke it shall remain nameless. It was the person behind the jsmime change who had sadly forgotten a few bits, which Kent then fixed, sadly only 97.5% optimally ;-)
(Assignee)

Comment 7

2 years ago
Yes, this needs uplift to the 38 branch.
Flags: needinfo?(squibblyflabbetydoo)

Comment 8

2 years ago
Comment on attachment 8629551 [details] [diff] [review]
Fix it

[Approval Request Comment]
Regression caused by (bug #): 1130248

Here you go.
Attachment #8629551 - Flags: approval-comm-esr38?
Attachment #8629551 - Flags: approval-comm-beta?
Attachment #8629551 - Flags: approval-comm-aurora?

Comment 9

2 years ago
Comment on attachment 8629551 [details] [diff] [review]
Fix it

https://hg.mozilla.org/releases/comm-aurora/rev/b18de0981b18
https://hg.mozilla.org/releases/comm-beta/rev/9ef3bdaaa318
https://hg.mozilla.org/releases/comm-esr38/rev/0f19fabeb6d1
Attachment #8629551 - Flags: approval-comm-esr38?
Attachment #8629551 - Flags: approval-comm-esr38+
Attachment #8629551 - Flags: approval-comm-beta?
Attachment #8629551 - Flags: approval-comm-beta+
Attachment #8629551 - Flags: approval-comm-aurora?
Attachment #8629551 - Flags: approval-comm-aurora+

Updated

2 years ago
status-thunderbird40: --- → wontfix
status-thunderbird41: --- → fixed
status-thunderbird42: --- → fixed
status-thunderbird43: --- → fixed
status-thunderbird_esr38: --- → fixed
tracking-thunderbird_esr38: --- → 41+
You need to log in before you can comment on or make changes to this bug.