[e10s] content process crashes often with many tabs open

RESOLVED DUPLICATE of bug 1155000

Status

()

RESOLVED DUPLICATE of bug 1155000
3 years ago
3 years ago

People

(Reporter: mikhail.v.gavrilov, Unassigned)

Tracking

({crash})

42 Branch
x86_64
Linux
crash
Points:
---

Firefox Tracking Flags

(e10s?)

Details

Attachments

(2 attachments)

1.18 MB, application/gzip
Details
7.52 KB, application/json
Details
(Reporter)

Comment 1

3 years ago
Also crashed still occurs on safe mode.
https://crash-stats.mozilla.com/report/index/bp-a8c6a8b9-1f3f-4d6c-b805-b4b792150704

Comment 3

3 years ago
There are three types of signatures here:
1) [@ mozalloc_abort(char const*) | NS_DebugBreak | mozilla::layers::PImageBridgeChild::SendPTextureConstructor(...) ] e.g. 76a9423b-fd27-4d7e-bc13-7a19a2150704
2) [@ mozilla::detail::AtomicBaseIncDec<T>::operator++() ] e.g. a34cb95f-d116-4dcb-9d2e-936002150704
3) the reports that didn't get symbolicated, e.g. 88dac00e-0e71-42ed-9950-05dc72150704

bug 1155000 shares the signature (1), and looks like an out-of-memory condition.
Depends on: 1155000
Keywords: crash
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Summary: it is impossible to use the browser because of a lot of crash when opened many tabs → [e10s] content process crashes often with many tabs open
Do you still see this? If so can you post your about:support and about:memory?
Flags: needinfo?(mikhail.v.gavrilov)
(Reporter)

Comment 5

3 years ago
Created attachment 8644620 [details]
memory-report.json.gz
Flags: needinfo?(mikhail.v.gavrilov)
(Reporter)

Comment 6

3 years ago
Created attachment 8644621 [details]
support.json

Comment 7

3 years ago
Note, the attached about:memory doesn't look like it was taken in e10s mode and has
2,605.29 MB ── resident
3,303.34 MB ── resident-peak

at least 1/3 of that is from the 2000+ open (crashed) tabs, and about:support lists a few add-ons.
tracking-e10s: --- → ?
the majority of your crash signatures are 

[@ mozalloc_abort(char const*) | NS_DebugBreak | mozilla::layers::PImageBridgeChild::SendPTextureConstructor(mozilla::layers::PTextureChild*, mozilla::layers::SurfaceDescriptor const&, mozilla::layers::TextureFlags const&) ]

as such, duping to 1155000
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1155000
You need to log in before you can comment on or make changes to this bug.