Closed Bug 1155000 Opened 7 years ago Closed 5 years ago

crash in mozalloc_abort(char const*) | NS_DebugBreak | mozilla::layers::PImageBridgeChild::SendPTextureConstructor(mozilla::layers::PTextureChild*, mozilla::layers::SurfaceDescriptor const&, mozilla::layers::TextureFlags const&)

Categories

(Core :: General, defect, P2)

All
Linux
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
e10s + ---
firefox40 --- affected

People

(Reporter: kbrosnan, Unassigned)

References

()

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-91ca0d51-243f-4d3e-b70f-470dd2150415.
=============================================================
I get this crash in e10s mode but not when it is turned off.
tracking-e10s: --- → ?
Flags: needinfo?(gwright)
Kevin, can you post your about:support? I can't reproduce this on Fedora with nightly when visiting http://people.mozilla.org/~kbrosnan/tmp/1155000/video-memory-test.html. If I try and visit http://people.mozilla.org/~kbrosnan/tmp/1155000/91ca0d51-243f-4d3e-b70f-470dd2150415.zip it just prompts me to load it in the archive manager (as I would expect).
Flags: needinfo?(gwright) → needinfo?(kbrosnan)
Just reproduced this crash had an uptime of 728. On a completely fresh profile/updated nightly.

Application Basics
------------------

Name: Firefox
Version: 40.0a1
Build ID: 20150422030206
Update Channel: nightly
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:40.0) Gecko/20100101 Firefox/40.0
Multiprocess Windows: 1/1 (default: true)

Crash Reports for the Last 3 Days
---------------------------------

Report ID: bp-cc435f03-c017-417e-92b5-a5e4d2150422
Submitted: 1 minute ago

All Crash Reports

Extensions
----------

Graphics
--------

Adapter Description: Intel Open Source Technology Center -- Mesa DRI Intel(R) Haswell Mobile
Asynchronous Pan/Zoom: none
Device ID: Mesa DRI Intel(R) Haswell Mobile
Driver Version: 3.0 Mesa 10.5.3
GPU Accelerated Windows: 0/1 Basic (OMTC)
Vendor ID: Intel Open Source Technology Center
WebGL Renderer: Intel Open Source Technology Center -- Mesa DRI Intel(R) Haswell Mobile
windowLayerManagerRemote: true
AzureCanvasBackend: cairo
AzureContentBackend: cairo
AzureFallbackCanvasBackend: none
AzureSkiaAccelerated: 0

Important Modified Preferences
------------------------------

browser.cache.disk.capacity: 358400
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.smart_size.first_run: false
browser.cache.frecency_experiment: 4
browser.download.importedFromSqlite: true
browser.places.smartBookmarksVersion: 7
browser.sessionstore.upgradeBackup.latestBuildID: 20150422030206
browser.startup.homepage_override.buildID: 20150422030206
browser.startup.homepage_override.mstone: 40.0a1
dom.apps.reset-permissions: true
dom.mozApps.used: true
extensions.lastAppVersion: 40.0a1
media.gmp-gmpopenh264.lastUpdate: 1429740429
media.gmp-gmpopenh264.version: 1.3
media.gmp-manager.buildID: 20150422030206
media.gmp-manager.lastCheck: 1429740528
network.cookie.prefsMigrated: true
network.predictor.cleaned-up: true
places.history.expiration.transient_current_max_pages: 104858
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
privacy.sanitize.migrateFx3Prefs: true

Important Locked Preferences
----------------------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.10.8
Version in use: 4.10.8

NSS
Expected minimum version: 3.19 Basic ECC Beta
Version in use: 3.19 Basic ECC Beta

NSSSMIME
Expected minimum version: 3.19 Basic ECC Beta
Version in use: 3.19 Basic ECC Beta

NSSSSL
Expected minimum version: 3.19 Basic ECC Beta
Version in use: 3.19 Basic ECC Beta

NSSUTIL
Expected minimum version: 3.19 Beta
Version in use: 3.19 Beta

Experimental Features
---------------------

Sandbox
-------

Seccomp-BPF (System Call Filtering): true
Seccomp Thread Synchronization: true
User Namespaces: false
Media Plugin Sandboxing: true
Flags: needinfo?(kbrosnan)
There are just two reports of this crash.  I assume those are both from Kevin's machine. Kevin, I wonder what is specific about your setup?  That and do we have many Linux users on Nightly?  marking tracking-e10s +. But please renom if a significant volume of crashes begins to be reported.
Blocks: 1180408
Duplicate of this bug: 1180408
Crash Signature: [@ mozalloc_abort(char const*) | NS_DebugBreak | mozilla::layers::PImageBridgeChild::SendPTextureConstructor(mozilla::layers::PTextureChild*, mozilla::layers::SurfaceDescriptor const&, mozilla::layers::TextureFlags const&)] → [@ mozalloc_abort(char const*) | NS_DebugBreak | mozilla::layers::PImageBridgeChild::SendPTextureConstructor(mozilla::layers::PTextureChild*, mozilla::layers::SurfaceDescriptor const&, mozilla::layers::TextureFlags const&)] [@ mozalloc_abort | NS_DebugBr…
I still encounter regular crashing when browsing imgur (let's say it crashes every 20-50 posts).
https://crash-stats.mozilla.com/report/index/aee14ef5-d336-4fda-833b-de2d72151206
A different signature today (same STR): https://crash-stats.mozilla.com/report/index/16c14620-e225-42a8-925b-0e95d2151227

[@ mozalloc_abort | NS_DebugBreak | mozilla::layers::PImageBridgeChild::SendPImageContainerConstructor ] (I'm not allowed to edit the signatures list)
Priority: -- → P2
See Also: → 1298158
I'm marking this bug as WORKSFORME as bug crashlog signature didn't appear from a long time (over half year) [except some obsolete <48 versions, no crashes starting since 48 version].
Status: NEW → RESOLVED
Crash Signature: , mozilla::layers::TextureFlags const&)] [@ mozalloc_abort | NS_DebugBreak | mozilla::layers::PImageBridgeChild::SendPTextureConstructor] → , mozilla::layers::TextureFlags const&)] [@ mozalloc_abort | NS_DebugBreak | mozilla::layers::PImageBridgeChild::SendPTextureConstructor] [@ mozalloc_abort | NS_DebugBreak | mozilla::layers::PImageBridgeChild::SendPImageContainerConstructor]
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.