Closed Bug 1180593 Opened 5 years ago Closed 5 years ago

[Messages][NG] Reorganize settings methods for settings service and views separately

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
FxOS-S3 (24Jul)

People

(Reporter: steveck, Assigned: steveck)

References

Details

(Whiteboard: [sms-sprint-FxOS-S3])

Attachments

(1 file)

Based on the discussion in bug 1179628, some methods seems better to live in views instead of service. We'll need to rethink the proper set of methods that exposed by settings service.
Assignee: nobody → schung
Status: NEW → ASSIGNED
Comment on attachment 8634593 [details] [review]
[gaia] steveck-chung:new-message-settings > mozilla-b2g:master

Hi Oleg, it's small patch that moves some settings methods to view/utils to reduce the complexity of settings service. In this patch I also remove mozl10n.get and utilize the notification helper for sending notification.
Attachment #8634593 - Flags: review?(azasypkin)
Comment on attachment 8634593 [details] [review]
[gaia] steveck-chung:new-message-settings > mozilla-b2g:master

Looks good! Just one question regarding NotificationHelper.send and few minor nits at Github.

Thanks!
Attachment #8634593 - Flags: review?(azasypkin) → review+
Thanks!

In master: https://github.com/mozilla-b2g/gaia/commit/0874358f7622392886d80be22dcb1aab5868a271
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S3 (24Jul)
Duplicate of this bug: 1170461
Whiteboard: [sms-sprint-FxOS-S3]
Target Milestone: FxOS-S3 (24Jul) → ---
Target Milestone: --- → FxOS-S3 (24Jul)
You need to log in before you can comment on or make changes to this bug.