Text inside text bubbles should always be aligned according to the text direction

VERIFIED FIXED in Firefox 42

Status

Hello (Loop)
Client
P2
normal
Rank:
25
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: bogdan_maris, Assigned: mai)

Tracking

unspecified
mozilla42
Points:
2
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox42 verified)

Details

(Whiteboard: [chat])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8629847 [details]
Screenshot showing the issue

Affected builds:
- latest Aurora 41.0a2
- latest Nighty 42.0a1

Affected OS`s:
- Windows 7 64-bit
- Ubuntu 14.04 32-bit
- Mac OS X 10.10

STR:
1. Start Firefox
2. Start a Conversation
3. Join the conversation from a new tab/different browser or PC
4. In the textarea write a long string 
eg:
'Lorem ipsum dolor sit amet, consectetur adipiscing elit. Proin commodo convallis risus, in tincidunt mi ullamcorper non. Aliquam tortor nibh, feugiat ac sem sed, tristique elementum quam. Fusce mattis faucibus imperdiet. Curabitur quis enim eu nibh porttitor vulputate at pulvinar elit. Suspendisse et dolor iaculis, viverra purus quis, iaculis lectus. In gravida nibh dui, eget molestie lorem viverra quis. Nunc eleifend justo diam, vel venenatis libero porta sed. '

Expected results: The text is aligned to left for non l10n languages, for l10n I don`t know what is the expected result here.

Actual results: The text is aligned to right for the user that types (conversation window or Standalone).

Notes:
- This is not a regression, it reproduces since chat was introduced by default in Nightly.
- Screenshot showing the issue attached
Summary: Align the text to left for the user that types → Text inside text bubbles should always be aligned according to the text direction
Points: --- → 2
Rank: 25
Priority: -- → P2
(Assignee)

Updated

3 years ago
Assignee: nobody → marina.rodrigueziglesias

Updated

3 years ago
Flags: qe-verify+
Flags: firefox-backlog+
(Assignee)

Comment 1

3 years ago
Created attachment 8632745 [details] [diff] [review]
0001-Bug-1180603-Text-inside-text-bubbles-should-always-b.patch
(Assignee)

Comment 2

2 years ago
Comment on attachment 8632745 [details] [diff] [review]
0001-Bug-1180603-Text-inside-text-bubbles-should-always-b.patch

Hi, 
would you mind reviewing the patch?
Regards
Attachment #8632745 - Flags: review?(mdeboer)
Comment on attachment 8632745 [details] [diff] [review]
0001-Bug-1180603-Text-inside-text-bubbles-should-always-b.patch

Well, excellent! LGTM :)
Attachment #8632745 - Flags: review?(mdeboer) → review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed

Comment 4

2 years ago
https://hg.mozilla.org/integration/fx-team/rev/ccbfb04250cb
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/ccbfb04250cb
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox42: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla42

Updated

2 years ago
Iteration: --- → 42.1 - Jul 13
(Reporter)

Comment 6

2 years ago
I just tested this on latest Nightly 42.0a1 with both loop servers, the default one and 'https://loop-dev.stage.mozaws.net/v0' but I don't see this issue fixed. It looks exactly the same as before. Any ideas why?

Here is a screenshot of how it looks now:
https://dl.dropboxusercontent.com/u/109148197/Hello%20Context/Screenshot%20from%202015-08-06%2012%3A27%3A03.png
Flags: needinfo?(marina.rodrigueziglesias)
It looks like bug 1183576 regressed this change, but I can't see why on that bug - Marina, do you know if reverting this change was intentional or not?
(Assignee)

Comment 8

2 years ago
Hi, 
the revertion was unintentional, I think it was a bad rebase of the bug 1183579 patch.
Flags: needinfo?(marina.rodrigueziglesias)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 9

2 years ago
https://hg.mozilla.org/integration/fx-team/rev/0cd73195817b
Ok, I've re-landed this. Thanks for catching it Bogdan.

Comment 11

2 years ago
This landed yesterday - https://hg.mozilla.org/mozilla-central/rev/0cd73195817b
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

2 years ago
Verified as fixed in Firefox 42beta3 across platforms (Windows 7 64-bit, Mac OS X 10.10.5 and Ubuntu 14.04 32-bit).
Status: RESOLVED → VERIFIED
status-firefox42: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.