Closed Bug 1180700 Opened 5 years ago Closed 4 years ago

Favicon missing from StandaloneUI context, when comments field contains long word, more then 20 characters

Categories

(Hello (Loop) :: Client, defect)

defect
Not set
Points:
1

Tracking

(firefox40 affected, firefox41+ fixed, firefox42+ verified)

VERIFIED FIXED
mozilla42
Iteration:
42.2 - Jul 27
Tracking Status
firefox40 --- affected
firefox41 + fixed
firefox42 + verified

People

(Reporter: bogdan_maris, Assigned: standard8)

References

Details

(Whiteboard: [context])

Attachments

(2 files)

Affected builds:
- latest Aurora 41.0a2
- latest Nighty 42.0a1

Affected OS`s:
- Windows 7 64-bit
- Ubuntu 14.04 32-bit
- Mac OS X 10.10

STR:
1. Start Firefox
2. Visit a webpage eg: https://www.mozilla.org/en-US/firefox/hello/
3. Click Hello icon
4. Tick 'Let`s talk about'
5. Start a conversation
6. Join a conversation
7. Edit context and enter a longer string (>=20 characters) eg: Antidisestablishmentarianism

Expected results: Favicon is still displayed and text is wrapped in context area.

Actual results: Favicon is missing and text is not wrapped in context area, horizontal scrollbar appears. 
This could impact other languages that have long words eg: de build.

Notes:
- Screenshot attached showing the issue.
- This is not a regression, I can reproduce on old Nightly build from 2015-05-08.
The favicon issue has been fixed by bug 1183187. However, the non-existant wrapping remains. We can fix this quite simply by using a similar method to what we use for the text chat fields.

We do unfortunately need to do a calculation to set the width though.

This will also fix the panel, if a website ever had a really long word in its title.
Attachment #8636627 - Flags: review?(mdeboer)
Tracking flag for FF41, FF42.
Assignee: nobody → standard8
Iteration: --- → 42.2 - Jul 27
Points: --- → 1
Comment on attachment 8636627 [details] [diff] [review]
Fix wrapping of context information when comments field contains a long word.

Review of attachment 8636627 [details] [diff] [review]:
-----------------------------------------------------------------

I like. Thanks!
Attachment #8636627 - Flags: review?(mdeboer) → review+
Comment on attachment 8636627 [details] [diff] [review]
Fix wrapping of context information when comments field contains a long word.

Approval Request Comment
[Feature/regressing bug #]: Context for conversations
[User impact if declined]: If a website title includes a very long word, or if the user inserts one, then this may cause bad display of the context information in the Hello panel or conversation window (text overlapping the edge of the panel)
[Describe test coverage new/current, TreeHerder]: N/A css only
[Risks and why]: Low, minor css change
[String/UUID change made/needed]: None
Attachment #8636627 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/d04749c1f834
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
Bogdan, could you please verify the fix works as expected? Thanks!
Flags: needinfo?(bogdan.maris)
Comment on attachment 8636627 [details] [diff] [review]
Fix wrapping of context information when comments field contains a long word.

Simple fix, uplift to Aurora makes sense.
Attachment #8636627 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(In reply to Ritu Kothari (:ritu) from comment #7)
> Bogdan, could you please verify the fix works as expected? Thanks!

I confirm that using latest Nightly and 'loop.server' 'https://loop-dev.stage.mozaws.net/v0' the issue does not reproduce anymore across platforms (Windows 10 32-bit, Ubuntu 14.04 32-bit and Mac OS X 10.10.4), text is wrapping nicely. Marking as verified since it reached it`s target milestone.
Status: RESOLVED → VERIFIED
Flags: needinfo?(bogdan.maris)
You need to log in before you can comment on or make changes to this bug.