Closed Bug 1180761 Opened 6 years ago Closed 6 years ago

[e10s] Space to mark checkbox scrolls page too

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

x86_64
Windows 7
defect
Not set
normal
Points:
2

Tracking

()

RESOLVED FIXED
mozilla44
Tracking Status
e10s + ---
firefox44 --- fixed

People

(Reporter: elbart, Assigned: enndeakin)

References

(Blocks 1 open bug, )

Details

Attachments

(2 files, 1 obsolete file)

STR:
- Visit URL
- Click "Log in or Sign up"
- Hit tab twice, the checkbox for "Stay logged in" should be focused
- Hit space

ER:
The checkbox is marked.

AR:
The checkbox is marked and the page is scrolled down.

Regression-range:

m-c:
Last good revision: 946ac85af8f4 (2015-04-22)
First bad revision: 0b202671c9e2 (2015-04-23)
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=946ac85af8f4&tochange=0b202671c9e2

m-i:
Last good revision: 13341fae85ed
First bad revision: 984018eae04a
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=13341fae85ed&tochange=984018eae04a

79aeff6684f6	Ehsan Akhgari — Bug 915962 - Part 1: Allow pressing space to scroll the document if an editable element or form control is not focused; r=roc
Blocks: fxe10s, 915962
Flags: needinfo?(ehsan)
Hmm, Neil, do you know how event handling is different on e10s?  Specifically, it seems like returning here <http://hg.mozilla.org/mozilla-central/rev/79aeff6684f6#l1.62> is not enough to tell the browser to not scroll.  What else should be done here?
Flags: needinfo?(ehsan) → needinfo?(enndeakin)
Attached file Testcase
Testcase.
Click anywhere, hit tab to focus the checkbox, and space to mark it.
(In reply to Ehsan Akhgari (not reviewing patches, not reading bugmail, needinfo? me!) from comment #1)
> Hmm, Neil, do you know how event handling is different on e10s? 
> Specifically, it seems like returning here
> <http://hg.mozilla.org/mozilla-central/rev/79aeff6684f6#l1.62> is not enough
> to tell the browser to not scroll.  What else should be done here?

Looks like this code is being run in the child process correctly and then again in the parent process, where the focused element is a <browser>, so the form control check fails.
Flags: needinfo?(enndeakin)
Assignee: nobody → ehsan
tracking-e10s: --- → +
I'm not the right person to fix this.  I am not sure if I even understand comment 3, and have no clue what it would take to fix this.
Assignee: ehsan → nobody
Duplicate of this bug: 1186217
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 1187703
Duplicate of this bug: 1207606
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Points: --- → 2
Don't really like having to add the special commands to handle the 'browser.backspace_action' but can't think of a better way right now.
Attachment #8666693 - Flags: review?(neil)
(In reply to Neil Deakin from comment #8)
> Move special case into controller
So how does this change actually end up fixing the bug?

> Don't really like having to add the special commands to handle the
> 'browser.backspace_action' but can't think of a better way right now.
Surely this breaks the Page Up and Page Down keys when a form control is focused? Maybe add special commands to handle the space action instead? (Why) Doesn't the form control prevent the space action anyway?

Also what's with the change to IsCommandEnabled?
This is a simpler fix.
Attachment #8666693 - Attachment is obsolete: true
Attachment #8666693 - Flags: review?(neil)
Attachment #8667029 - Flags: review?(neil)
Comment on attachment 8667029 [details] [diff] [review]
Different approach

Wow, that was simple!
Attachment #8667029 - Flags: review?(neil) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/6fff7b56c8659f0ea90fefdb772095f633295723
Bug 1180761, cancel the event earlier so that space doesn't trigger checkbox change and scroll, r=neil
https://hg.mozilla.org/mozilla-central/rev/6fff7b56c865
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
I have reproduced this bug with Firefox Nightly 42.0a1 (Build ID : 20150706030206) on Windows 7(64-bit) with the instructions from comment 0.

Verified as fixed with Latest Firefox Beta 44.0b9 (Build ID : 20160114165817)

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0

[testday-20160115]
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.