Closed Bug 1180889 Opened 4 years ago Closed 3 years ago

imgur links on Facebook don't redirect properly

Categories

(Web Compatibility :: Desktop, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: mccr8, Assigned: karlcow)

References

()

Details

(Whiteboard: [country-all] [sitewait])

imgur.com seems to have recently switched over to using webm where possible. If I paste an imgur webm link directly in the address bar (like https://i.imgur.com/gcNEaJd.webm ) it seems to work just fine by redirecting me, but I'm having some trouble when I click on a link somebody has pasted into a Facebook conversation. Firefox gives me the error message "The page isn't redirecting properly

Firefox has detected that the server is redirecting the request for this address in a way that will never complete."

The link FB generates for the above image is (though it only seems to work if you are logged in to Facebook):
https://www.facebook.com/l.php?u=https%3A%2F%2Fi.imgur.com%2FgcNEaJd.webm&h=LAQFTG7uX

Presumably something FB is doing to track the link is confusing imgur. The redirect works for me sometimes but not always.
It's imgur redirecting, no idea why (sorry about the spoofed Chrome UA, I was testing with Firefox):

GET https://imgur.com/gcNEaJd.webm HTTP/1.1
Host: imgur.com
User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.132 Safari/537.36
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: no,en-US;q=0.8,en;q=0.5,fr;q=0.3
Accept-Encoding: gzip, deflate
DNT: 1
Referer: https://www.facebook.com/l.php?u=https%3A%2F%2Fi.imgur.com%2FgcNEaJd.webm&h=LAQFTG7uX
Cookie: __cfduid=d51b86a227507fb798505de4a01bbf0541386608261214; __qca=P0-917532968-1391156059829; __qseg=Q_D; __gads=ID=3e62eb26e5a76e73:T=1395028940:S=ALNI_MaQxINe9ZywSWdOktqZAqfeEbrKtQ; __utma=247341212.142293768.1405759749.1406198016.1419048952.3; optimizelySegments=%7B%222025850214%22%3A%22true%22%2C%221938330135%22%3A%22true%22%2C%221506465808%22%3A%22referral%22%2C%221717910483%22%3A%22none%22%2C%221505515733%22%3A%22false%22%2C%221503675771%22%3A%22ff%22%2C%221893480508%22%3A%22true%22%2C%221933410265%22%3A%22true%22%2C%222359290357%22%3A%22true%22%7D; optimizelyEndUserId=oeu1412434509860r0.5356448380448656; optimizelyBuckets=%7B%7D; _ga=GA1.2.142293768.1405759749; IMGURUIDJAFO=0a79446b03faa43f5b33113bb5139d059e47ba9ef83c1924ea931dad89c33cc2; IMGUR-UID=5110cf3a0f0e0b0032c7560e79f9dff1db18393940bea95372220ec3e0e7779b
Connection: keep-alive


HTTP/1.1 302 Moved Temporarily
Retry-After: 0
Location: https://i.imgur.com/gcNEaJd.webm
Content-Length: 0
Accept-Ranges: bytes
Date: Mon, 13 Jul 2015 21:18:19 GMT
Connection: close
X-Served-By: cache-fra1225-FRA
X-Cache: HIT
X-Cache-Hits: 0
Server: cat factory 1.0
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0



------------------------------------------------------------------
GET https://i.imgur.com/gcNEaJd.webm HTTP/1.1
Host: i.imgur.com
User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.132 Safari/537.36
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: no,en-US;q=0.8,en;q=0.5,fr;q=0.3
Accept-Encoding: gzip, deflate
DNT: 1
Referer: https://www.facebook.com/l.php?u=https%3A%2F%2Fi.imgur.com%2FgcNEaJd.webm&h=LAQFTG7uX
Cookie: __cfduid=d51b86a227507fb798505de4a01bbf0541386608261214; __qca=P0-917532968-1391156059829; __qseg=Q_D; __gads=ID=3e62eb26e5a76e73:T=1395028940:S=ALNI_MaQxINe9ZywSWdOktqZAqfeEbrKtQ; __utma=247341212.142293768.1405759749.1406198016.1419048952.3; optimizelySegments=%7B%222025850214%22%3A%22true%22%2C%221938330135%22%3A%22true%22%2C%221506465808%22%3A%22referral%22%2C%221717910483%22%3A%22none%22%2C%221505515733%22%3A%22false%22%2C%221503675771%22%3A%22ff%22%2C%221893480508%22%3A%22true%22%2C%221933410265%22%3A%22true%22%2C%222359290357%22%3A%22true%22%7D; optimizelyEndUserId=oeu1412434509860r0.5356448380448656; optimizelyBuckets=%7B%7D; _ga=GA1.2.142293768.1405759749; IMGURUIDJAFO=0a79446b03faa43f5b33113bb5139d059e47ba9ef83c1924ea931dad89c33cc2; IMGUR-UID=5110cf3a0f0e0b0032c7560e79f9dff1db18393940bea95372220ec3e0e7779b
Connection: keep-alive


HTTP/1.1 302 Moved Temporarily
Retry-After: 0
Location: https://imgur.com/gcNEaJd.webm
Content-Length: 0
Accept-Ranges: bytes
Date: Mon, 13 Jul 2015 21:18:19 GMT
Connection: close
X-Served-By: cache-fra1240-FRA
X-Cache: HIT
X-Cache-Hits: 0
X-Timer: S1436822299.644489,VS0,VE0
Access-Control-Allow-Methods: GET, OPTIONS
Access-Control-Allow-Origin: *
Server: cat factory 1.0



------------------------------------------------------------------
GET https://imgur.com/gcNEaJd.webm HTTP/1.1
Host: imgur.com
User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.132 Safari/537.36
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: no,en-US;q=0.8,en;q=0.5,fr;q=0.3
Accept-Encoding: gzip, deflate
DNT: 1
Referer: https://www.facebook.com/l.php?u=https%3A%2F%2Fi.imgur.com%2FgcNEaJd.webm&h=LAQFTG7uX
Cookie: __cfduid=d51b86a227507fb798505de4a01bbf0541386608261214; __qca=P0-917532968-1391156059829; __qseg=Q_D; __gads=ID=3e62eb26e5a76e73:T=1395028940:S=ALNI_MaQxINe9ZywSWdOktqZAqfeEbrKtQ; __utma=247341212.142293768.1405759749.1406198016.1419048952.3; optimizelySegments=%7B%222025850214%22%3A%22true%22%2C%221938330135%22%3A%22true%22%2C%221506465808%22%3A%22referral%22%2C%221717910483%22%3A%22none%22%2C%221505515733%22%3A%22false%22%2C%221503675771%22%3A%22ff%22%2C%221893480508%22%3A%22true%22%2C%221933410265%22%3A%22true%22%2C%222359290357%22%3A%22true%22%7D; optimizelyEndUserId=oeu1412434509860r0.5356448380448656; optimizelyBuckets=%7B%7D; _ga=GA1.2.142293768.1405759749; IMGURUIDJAFO=0a79446b03faa43f5b33113bb5139d059e47ba9ef83c1924ea931dad89c33cc2; IMGUR-UID=5110cf3a0f0e0b0032c7560e79f9dff1db18393940bea95372220ec3e0e7779b
Connection: keep-alive


HTTP/1.1 302 Moved Temporarily
Retry-After: 0
Location: https://i.imgur.com/gcNEaJd.webm
Content-Length: 0
Accept-Ranges: bytes
Date: Mon, 13 Jul 2015 21:18:20 GMT
Connection: close
X-Served-By: cache-fra1242-FRA
X-Cache: HIT
X-Cache-Hits: 0
Server: cat factory 1.0
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0



------------------------------------------------------------------

Seems where Imgur actually wants to take you is https://i.imgur.com/gcNEaJd.gifv
Might it be affected by the referrer or something? Oddly, if I've pasted the direct imgur link, redirect worked and afterwards the FB->Imgur redirect also works.
(In reply to Hallvord R. M. Steen [:hallvors] from comment #2)
> Oddly, if I've pasted the direct imgur link, redirect worked and afterwards the FB->Imgur redirect
> also works.

Yeah, I noticed the same thing.
TIL Imgur users are called "imgurians" ;)

I posted the WEBM link from Andrew here for testing:
https://m.facebook.com/home.php?s=100006763626692&sstr=1689538384614933&stype=s&gfid=AQAvBi6fgS-Pv7A1&_rdr#!/story.php?story_fbid=1689538384614933&id=100006763626692
Whiteboard: [country-all] [needscontact]
Could it be related to cookies and tracking protections?

Is there a different behavior if privacy.trackingprotection.enabled is true or false in about:config?


Also some other imgur issues:
Bug 1185226 - "Save video as" failed to retrieve webm from imgur, giving me gifv instead.
Bug 1073120 - [Imgur] imgur only supports photo file types, but doesn't warn a user who tries to upload another file type
and https://bugzilla.mozilla.org/buglist.cgi?quicksearch=imgur&list_id=12494562


CONTACTS:
Note that https://github.com/Imgur has a repo on github.
Maybe https://twitter.com/briankassouf can help us.
Flags: needinfo?(hsteen)
Whiteboard: [country-all] [needscontact] → [country-all] [contactready]
First attempt at contact
http://twitter.com/MozWebCompat/status/635598911302840320
Assignee: nobody → kdubost
Status: NEW → ASSIGNED
Whiteboard: [country-all] [contactready] → [country-all] [sitewait]
Tracking protection makes no difference.

Steps to reproduce: 
1) Load https://www.facebook.com/permalink.php?story_fbid=1689538384614933&id=100006763626692&pnref=story
2) Click the imgur link in that post
3) If you get an error screen saying "the page is not redirecting properly" you've found the problem.
Flags: needinfo?(hsteen)
→ http --print hH GET https://imgur.com/gcNEaJd.webm 'User-Agent:Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:48.0) Gecko/20100101 Firefox/48.0'
GET /gcNEaJd.webm HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate
Connection: keep-alive
Host: imgur.com
User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:48.0) Gecko/20100101 Firefox/48.0

HTTP/1.1 302 Moved Temporarily
Accept-Ranges: bytes
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Connection: close
Content-Length: 0
Date: Mon, 06 Jun 2016 10:00:31 GMT
Location: https://i.imgur.com/gcNEaJd.webm
Retry-After: 0
Server: cat factory 1.0
X-Cache: HIT
X-Cache-Hits: 0
X-Frame-Options: DENY
X-Served-By: cache-lhr6334-LHR






→ http --print hH GET https://i.imgur.com/gcNEaJd.webm 'User-Agent:Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:48.0) Gecko/20100101 Firefox/48.0'
GET /gcNEaJd.webm HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate
Connection: keep-alive
Host: i.imgur.com
User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:48.0) Gecko/20100101 Firefox/48.0

HTTP/1.1 200 OK
Accept-Ranges: bytes
Access-Control-Allow-Methods: GET, OPTIONS
Access-Control-Allow-Origin: *
Age: 6307450
Connection: keep-alive
Content-Length: 937607
Content-Type: video/webm
Date: Mon, 06 Jun 2016 10:01:48 GMT
ETag: "fafb4087124980c85b08a6f7c6347c8f"
Fastly-Debug-Digest: 283a48ad99b3b1395c4cd754f2520105343c6d8d54754c97d6df503c791a879f
Last-Modified: Mon, 06 Jul 2015 10:26:28 GMT
Server: cat factory 1.0
X-Cache: HIT, HIT
X-Cache-Hits: 1, 1
X-Served-By: cache-iad2123-IAD, cache-lhr6341-LHR
X-Timer: S1465207308.862518,VS0,VE1
cache-control: public, max-age=31536000


Andrew: This seems to be fixed?
Flags: needinfo?(continuation)
I haven't noticed this for a while.
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Flags: needinfo?(continuation)
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.