Closed Bug 1180909 Opened 6 years ago Closed 6 years ago

Marketplace loads a blank screen in 2.0 because of JavaScript Error: "TypeError: navigator.hasFeature is not a function"

Categories

(Marketplace Graveyard :: Consumer Pages, defect, P1)

x86
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

VERIFIED FIXED
2015-07-07

People

(Reporter: krupa.mozbugs, Assigned: mat)

References

Details

(Keywords: regression)

Attachments

(4 files)

Connectivity: wifi
SIM used: n/a
Gaia/device: flame/20150706000206; 2015-07-02 23:35:32 43607033


steps to reproduce:
1. Flash the latest 2.0 engineering build from https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-b2g32_v2_0-flame-kk-eng/latest/
2. Launch marketplace prod

expected behavior:
Marketplace loads without any errors


actual behavior:
Marketplace homepage is blank because of the JS error

07-06 23:08:45.479 E/GeckoConsole( 1439): [JavaScript Error: "TypeError: navigator.hasFeature is not a function" {file: "app://marketplace.firefox.com/main.js" line: 91}]

I couldn't reproduce this issue on 2.1
Sigh. Yes, 2.0 has no hasFeature(). I forgot about that mess when implementing OpenMobile stuff... I'll need to rip it out completely and add a big fat warning in the code and in the docs to prevent that from happening again.

Bad news is that means we'll need to push a new dev/stage/prod package (prompting another update to users) and put them in gaia as well.
Assignee: nobody → mpillard
Priority: -- → P1
Target Milestone: --- → 2015-07-07
Duplicate of this bug: 1181077
Status: NEW → ASSIGNED
Fixed in https://github.com/mozilla/fireplace/commit/40c694127c4128c7f8554b928f2a8830bd87a76d

We will need to generate a new dev/stage/prod package (and push those in gaia), so not closing till this is done.
Duplicate of this bug: 1180392
Attachment #8630712 - Flags: review?(fabrice) → review+
Could you merge the PR for me if it looks good? Thanks!
https://github.com/mozilla-b2g/gaia/commit/b16ba05481e577bc644ed8966f587a70fe2148e6
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Fabrice, by approving the PR does this automatically end up on 2.0M or do we need an additional uplift?
Flags: needinfo?(fabrice)
I forgot to do 2.0M...
Status: RESOLVED → REOPENED
Flags: needinfo?(fabrice)
Resolution: FIXED → ---
Here's a patch for v2.0m, sorry about forgetting it. Thanks for sheparding these patches.
Attachment #8631145 - Flags: review?(fabrice)
Attachment #8631145 - Flags: review?(fabrice) → review+
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
We probably need all other branches right ? In https://bugzilla.mozilla.org/show_bug.cgi?id=1172197 we updated 2.2, 2.1S, 2.1, 2.0 as well.
(In reply to Kevin Ngo [:ngoke] from comment #12)
> Created attachment 8631145 [details] [review]
> Pull Request v2.0m for Marketplace
> 
> Here's a patch for v2.0m, sorry about forgetting it. Thanks for sheparding
> these patches.

For future reference, v2.0 is merged to v2.0m, so you don't need to double-land. This is explained on the B2G Landing page.
https://wiki.mozilla.org/Release_Management/B2G_Landing
Okay, good to know.

I don't think we need this on 2.1+ if it's a bugfix for 2.0.
Duplicate of this bug: 1176689
Verified as fixed on FF OS 2.0(Flame).
All MP apps are starting as expected, after reinstalling them.
Closing bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.