SVG displayed in shades of blue and magenta

VERIFIED DUPLICATE of bug 111152

Status

()

Core
SVG
VERIFIED DUPLICATE of bug 111152
17 years ago
13 years ago

People

(Reporter: P. Damian Cugley, Assigned: Alex Fritze)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(5 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.7) Gecko/20020102
BuildID:    2002010204

SVG files (with .xml suffix, opresumably served
as text/xml) display as SVG, which is nice,
but in shades of blue and magenta, which seems odd.
The cute lion picture cited above is an example,
but other SVG files exhibit the same behaviour.

I can't compare this directly with Adobe's SVG viewer,
because Microsoft Itnernet Explorer displays the XML
as XML (not graphics).


Reproducible: Always
Steps to Reproduce:
1. visit http://www.croczilla.com/svg/lion.xml
(using Mozilla with SVG compiled in).

2. Observe that it is blue.

Actual Results:  Lion is outlined in blue with lighter blue and pink shading.

Expected Results:  I expected it to be outlined in black (or brown-black)
and coloured in shades of light brown.

Comment 1

17 years ago
I see this too, using 0.9.7 with SVG from the releases page (build 2002010204).
But using the experimental build 2002010209 SVG colors display fine. The UA
string of this experimental build (from the ftp site) is

Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:0.9.7+) Gecko/20010929

An oddity is the oldness of the Gecko number. I don't know if this has anything
to do with the SVG rendering, though.
(Assignee)

Updated

17 years ago
Status: UNCONFIRMED → ASSIGNED
Depends on: 111152
Ever confirmed: true

Comment 2

17 years ago
I am seeing something similar with 0.9.7 (Win98SE) but with different colours. 
Most of the croczilla examples display in red, giving a decidedly pink lion.  It
all seems to work, though, apart from that - I'm glad this is finally in.

Comment 3

17 years ago
Ditto on that, in this file http://www.croczilla.com/svg/polygons3.xml
the rectangle in yellow is missing, in that the color is not there and
I don't see another color for it at all and the two polygons are the wrong color.
In build id # 2002010412 (win experimental) it looks fine.

Comment 4

17 years ago
Created attachment 64231 [details]
Testcase with various colors

Comment 5

17 years ago
Created attachment 64233 [details]
Shot of testcase in 0.9.7 {2002010204} (Zip file with MathML and SVG (9.1 MB) from the Releases page)

Comment 6

17 years ago
Created attachment 64234 [details]
Shot of testcase in experimental build {2002010710}

Comment 7

17 years ago
Created attachment 64656 [details]
Shot of testcase on 0.9.7 Linux build

RH 7.2 Linux and mozilla-i686-pc-linux-gnu-0.9.7-MathML-SVG-XMLterm.tar.gz

Comment 8

17 years ago
Is this possibly similar to bug 116378?

Comment 9

17 years ago
Hi All
Colors now look correct in Build ID # 2002 01 10 10.
Not a bad build in other areas also.

Comment 10

17 years ago
I'm running the SVG/MathML build 2002011509 on w98 and apparently the red and
blue channels are swapped.  I'll attach a screenshot of the testcase.

Comment 11

17 years ago
Created attachment 65241 [details]
Shot of testcase with 2002011509 w98
I'm using 2002-01-16-04 on Win32 (WinXP Pro), and it doesn't seem to support SVG
at all. I thought I had read on npm.svg that Win32 nightlies would now have SVG
support built in again? The experimental folder doesn't seem to be updated any
more either since 7th. So where are the SVG Win32 builds hiding?

Comment 14

17 years ago
Two issues here:

I have two seperate boxes. Both are exhibiting the same behavior: on my Win32
box, SVG is rendered syntactically correct with one exception: everything is
purple and blue. Items that are supposed to be yellow are rendered invisibly.
Every single example on croczilla.org renders this way. I have an NVidia TNT
video card w/ the latest Win2k drivers. However, embeded JPGs or PNGs render
with the correct collors.

On my linux box, again, everything is rendered as it should be, but, instead of
collors, I get interesting-looking-verticle-bars-of-various-colors effect. Also,
object roll over causes the SVG image to become distorted as opposed to changing
the collor. Animations work, but are also distorted. I have a Radeon on XFree86
4.1 on Kernel 2.4.17. Again, embedded JPGs and PNGs render withing an SVG frame
without color problems.

I have tried all the builds between Dec 22 and Jan 7 to no avail.

What, in techical terms, is causing the problem? I personally suspect libart.

BTW, keep up the good work guys. SVG in Mozilla rocks.

Comment 15

17 years ago
this is really bug 111152 - libart not doing native pixel formats correctly

24 bit on win32 and 16 bit on linux work best but have colors swapped

24 and 32 bit on linux is _real_ bad

*** This bug has been marked as a duplicate of 111152 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 16

17 years ago
Hi All

Here is a color test page using safe, named colors.
AT 16bit okay, at 32 bit, not okay.

http://www.skeeter-s.com/svg/color-test.xml

However also check out the Gecko Icon up in the left
Corner of the Browser, perhaps this means something else
Its color is also wrong at 32bit

-- 
steve
http://www.skeeter-s.com/svg
SVG examples for Mozilla unplugged

Updated

13 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.