localhost pages break after multiple restores

RESOLVED FIXED

Status

()

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: bnicholson, Assigned: bnicholson)

Tracking

unspecified
Other
iOS

Firefox Tracking Flags

(fxios+)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
I have found any reliable steps to reproduce, but after opening a tab with several pages and killing the browser multiple times, I run into an issue where the page doesn't load and the back/forward history stops working. Similar to 1181231, but I'm not restoring any error pages.

Updated

3 years ago
tracking-fxios: ? → +
(Assignee)

Comment 1

3 years ago
The back/forward breakage is probably due to bug 1182274.
Repro or WFM?
Status: ASSIGNED → NEW
Flags: needinfo?(aaron.train)
(Assignee)

Comment 3

3 years ago
Still reproducible. STR:
1) Create a new tab.
2) Go to any URL.
3) Close and reopen the browser.
4) Close and reopen the browser again.
5) Go back.

about:home the fails to load. Looks like it's related to localhost pages and multiple restores.
Status: NEW → ASSIGNED
Flags: needinfo?(aaron.train)
Summary: Session history intermittently breaks after restore → localhost pages break after multiple restores
(Assignee)

Comment 4

3 years ago
Created attachment 8643076 [details] [review]
Link to Github pull-request: https://github.com/mozilla/firefox-ios/pull/856
Attachment #8643076 - Flags: review?(sleroux)
Comment on attachment 8643076 [details] [review]
Link to Github pull-request: https://github.com/mozilla/firefox-ios/pull/856

I tested this by going in airplane mode to get an error page and did some restorations and it seems to work for me. Left a comment about something Emily landed earlier this morning that might effect this.
Attachment #8643076 - Flags: review?(sleroux) → review+
(Assignee)

Comment 6

3 years ago
https://github.com/mozilla/firefox-ios/commit/333208dfc4a7deadf676abc9b93fe814fe409ae4
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.