Closed Bug 1181882 Opened 5 years ago Closed 5 years ago

Hide find in page bar on HomePager

Categories

(Firefox for Android :: General, defect)

All
Android
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 42
Tracking Status
firefox42 --- fixed

People

(Reporter: mcomella, Assigned: mcomella, Mentored)

References

Details

Attachments

(1 file)

We hide it in showBrowserSearch but we should have hid it in showHomePager*.
Note: WIP builds on bug 1179731.

I tried the simple thing and just hid the find in page bar in showHomePagerWithAnimator, but when opening the HomePager w/ the find in page bar up, it causes the bar to close and reopen (which is more awful than having the find in page bar open on about:home).

In a non-attached patch, I also added a PropertyAnimationListener and tried hiding it at the end of the animation, but the keyboard and bar would close at the end of the animation, leaving the user in about:home without the home screen.

The latter is more likely the solution, with some refocus magic in place.

However, it's not worth the cycles to get this working now.
Assignee: michael.l.comella → nobody
Mentor: michael.l.comella, s.kaspari
i want to work on this bug. Am new here
Hi, Amit - you're welcome to give it a go! We'll assign you when you post a patch.

However, we typically recommend starting with a [good first bug], such as bug 1146735, which have minimal programming requirements so you can get used to the Mozilla tools and processes. If you'd like to work on that first, post a comment over there and the same deal applies - we'll assign you when you post a patch.

Additionally, this bug may be challenging because the obvious answer does not work (see the WIP) and soft keyboard control is typically more challenging than it should be.
Hey, Amit.

Turns out this unexpected behavior is fixed by the patch in bug 1181969 - it turns out the find in page bar closed the keyboard when it was hidden - and my WIP is correct.

Would you like to take bug 1146735 for now and I'll give you a more complex bug after that's completed?
Assignee: nobody → michael.l.comella
Attachment #8631363 - Attachment description: (WIP) Hide find in page bar when home pager is shown → Hide find in page bar when home pager is shown
Attachment #8631363 - Flags: review?(s.kaspari)
Comment on attachment 8631363 [details] [diff] [review]
Hide find in page bar when home pager is shown

Review of attachment 8631363 [details] [diff] [review]:
-----------------------------------------------------------------

Ship it! :)
Attachment #8631363 - Flags: review?(s.kaspari) → review+
url:        https://hg.mozilla.org/integration/fx-team/rev/190aee23c829cd5a89fcf5f3e219bc314f5830dd
changeset:  190aee23c829cd5a89fcf5f3e219bc314f5830dd
user:       Michael Comella <michael.l.comella@gmail.com>
date:       Wed Jul 08 18:03:15 2015 -0700
description:
Bug 1181882 - Hide find in page bar when home pager is shown. r=sebastian
https://hg.mozilla.org/mozilla-central/rev/190aee23c829
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 42
You need to log in before you can comment on or make changes to this bug.