Closed Bug 1182139 Opened 4 years ago Closed 4 years ago

Incorrect mouse coordinates inside bordered/margin div tag since Firefox 39

Categories

(Firefox :: Untriaged, defect)

39 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1175863

People

(Reporter: jkirk_14, Unassigned)

Details

(Keywords: testcase)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150630154324

Steps to reproduce:

A google map that is inside a div with any margin or padding has mouse coordinates offset by the same padding or margin.  See this JSFiddle: http://jsfiddle.net/fNPvf/15426/

The coordinates are read as 50,50 instead of 0,0 in FF 39.  Prior versions of FF, IE, and Chrome correctly show 0,0.



Actual results:

This causes tooltips or any other mouseover events to be offset, and interferes with google map functionality.  Another example, which works with mouseover in any other browser and FF prior to 39:  http://listsofjohn.com/qmap?lat=40.3005&lon=-105.6461&z=12&t=u&P=0

Note that tooltips work when 10 pixels to the left and 5 pixels above the map balloons.


Expected results:

Mouseover events should happen when the element is directly under the cursor, not offset by margin or padding.
Summary: Incorrect mouse coordinates inside padded/margin div tag since Firefox 39 → Incorrect mouse coordinates inside bordered/margin div tag since Firefox 39
Example where div border of 50 offsets mouse coords (tooltip appears when hovering 50 pixels left and above balloon):
http://jsfiddle.net/g0anx3q3/

Example where body margin of 50 offsets mouse coords (tooltip appears when hovering 50 pixels left and above balloon):
http://jsfiddle.net/sm38feso/
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Keywords: testcase
Resolution: --- → DUPLICATE
Duplicate of bug: 1171938
You need to log in before you can comment on or make changes to this bug.