Closed Bug 1175863 Opened 4 years ago Closed 4 years ago

Google Maps API V3 drawing manager bug (caused by Gecko now supporting event.offsetX/Y)

Categories

(Web Compatibility :: Desktop, defect)

Firefox 39
defect
Not set

Tracking

(firefox38 unaffected, firefox39+ wontfix, firefox38.0.5 unaffected, firefox40+ wontfix, firefox41+ wontfix, firefox-esr31 unaffected, firefox-esr38 unaffected)

RESOLVED FIXED
Tracking Status
firefox38 --- unaffected
firefox39 + wontfix
firefox38.0.5 --- unaffected
firefox40 + wontfix
firefox41 + wontfix
firefox-esr31 --- unaffected
firefox-esr38 --- unaffected

People

(Reporter: oskar, Unassigned)

References

()

Details

(Keywords: dev-doc-complete, regression, site-compat, Whiteboard: [js] [sitewait] [country-all])

Attachments

(1 file)

326.86 KB, image/jpeg
Details
Attached image bug.jpg
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150603092413

Steps to reproduce:

I was trying to draw a polygon by Drawing Manager.
Try here: http://codepen.io/anon/pen/LVzpGG


Actual results:

If the map DIV's parent has margin, polygon was showing end of new line in bad position.




Expected results:

It should work like in older versions of Firefox or like with no margin.
[Tracking Requested - why for this release]:regression since Firefox39beta
Pushlog: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=2b9f5019abf1&tochange=4100738d662d

Triggered by: Bug 69787

The following UA spoofing helps:
user_pref("general.useragent.override", "Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.65 Safari/537.36");

So this is also Google's bug. (See also Bug 1171938.)
Blocks: 69787
Tracked for 39, 40, and 41, as this is a regression, and the behavior was working in 39 Beta, and expectation would be that it would continue to.
Wontfix for 39.
Duplicate of this bug: 1180319
I vote for this bug to be solved soon, as it really makes Google Maps (with mouseevents on markers) unusable in FF (except if you position your map div at the topleft corner of your browser window).
Duplicate of this bug: 1182410
Duplicate of this bug: 1182478
Component: Untriaged → DOM: Events
Product: Firefox → Core
Not a Core bug actually.
Component: DOM: Events → Desktop
Product: Core → Tech Evangelism
Version: 39 Branch → Firefox 39
I consider them contacted since there's a bug report on https://code.google.com/p/gmaps-api-issues/issues/detail?id=8278
Summary: Google Maps API V3 drawing manager bug → Google Maps API V3 drawing manager bug (caused by Gecko now supporting event.offsetX/Y)
Whiteboard: [js] [sitewait] [country-all]
> Wontfix for 39.

Do we have a commitment from Google to fix their end of this?  Why did we decide to go ahead and ship bug 69787 given the known breakage?
Flags: needinfo?(roc)
On June 7 we were told "It has been assigned to someone last week." Then I kind of forgot about it :-(.

There's at least one site (not an important site) that's broken without offsetX/Y support, which is why I implemented it. We can expect that to grow since every other browser has had them for a long time. So, we could revert the patch, but then I'm not sure how to proceed so we can eventually enable offsetX/Y.

FWIW Google's internal bug number for this is b/20820906.
Flags: needinfo?(roc)
Since Maps API widgets don't have their own IFRAME, I guess hiding offsetX/Y from Google Maps but making them available to other code is not really an option.

Any suggestions to make Maps work that don't require disabling offsetX/Y indefinitely?
As per Bug 1181130 Firefox 38.0.1 is being planned. Could we just back out Bug 69787 from 38 so we give Google 4 weeks to fix the issue before 39 is out?
It is not only a problem on Google maps but also on openlayers 3
Not sure if this is because Google put in a fix already, but this seems to solve my problem with mouseover events:

In js source,
Change
http://maps.googleapis.com/maps/api/js?sensor=false
to
http://maps.googleapis.com/maps/api/js?v=3
Or works adding the v=3 parameter and keeping sensor=false:
http://maps.googleapis.com/maps/api/js?v=3&sensor=false

Working example:
http://jsfiddle.net/mojs7421/
Thanks for the input. It works much better.
Agreed, thank you jkirk, this helps avoiding the bug (not sure, if that is called a solution)...
Agreed - I'm not affiliated and just wanted to share a fix I found while we wait for Google/Mozilla to sort it out.  There's clearly something in the V3.exp API that differs from V3 and should be easy to pinpoint.
Duplicate of this bug: 1184299
Openlayers 3.7 seemed to have fixed the problem as well
Duplicate of this bug: 1186757
Duplicate of this bug: 1186731
Duplicate of this bug: 1186964
As it is not a Firefox bug per say and Google Map & Openlayers fixed the bug, I am going to wontfix it.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.