Last Comment Bug 1182208 - [AccessFu][Android] enabled support for range slider control.
: [AccessFu][Android] enabled support for range slider control.
Status: RESOLVED FIXED
: access
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: unspecified
: All All
-- normal (vote)
: mozilla43
Assigned To: Eitan Isaacson [:eeejay]
:
: alexander :surkov
Mentors:
: 1182219 (view as bug list)
Depends on:
Blocks: AndroidA11yUpdates
  Show dependency treegraph
 
Reported: 2015-07-09 11:28 PDT by Yura Zenevich [:yzen]
Modified: 2015-10-08 10:31 PDT (History)
5 users (show)
ryanvm: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Add support for android scrolling and range accessibility actions. (11.70 KB, patch)
2015-08-19 14:46 PDT, Eitan Isaacson [:eeejay]
yzenevich: review+
mark.finkle: review+
Details | Diff | Splinter Review

Description User image Yura Zenevich [:yzen] 2015-07-09 11:28:02 PDT
At the moment adjusting values for input range is not working on android. We need to figure out what action/event needs to happen when we want to increase or decrease range input's value.
Comment 1 User image Eitan Isaacson [:eeejay] 2015-08-19 14:36:01 PDT
*** Bug 1182219 has been marked as a duplicate of this bug. ***
Comment 2 User image Eitan Isaacson [:eeejay] 2015-08-19 14:46:02 PDT
Created attachment 8650143 [details] [diff] [review]
Add support for android scrolling and range accessibility actions.
Comment 3 User image Mark Finkle (:mfinkle) (use needinfo?) 2015-08-20 18:09:30 PDT
Comment on attachment 8650143 [details] [diff] [review]
Add support for android scrolling and range accessibility actions.

Seems fine to me.
Comment 4 User image Yura Zenevich [:yzen] 2015-08-21 08:10:01 PDT
Comment on attachment 8650143 [details] [diff] [review]
Add support for android scrolling and range accessibility actions.

Review of attachment 8650143 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, just one comment to address

::: accessible/jsat/AccessFu.jsm
@@ +134,5 @@
>      Services.obs.addObserver(this, 'Accessibility:Focus', false);
>      Services.obs.addObserver(this, 'Accessibility:ActivateObject', false);
>      Services.obs.addObserver(this, 'Accessibility:LongPress', false);
> +    Services.obs.addObserver(this, 'Accessibility:ScrollForward', false);
> +    Services.obs.addObserver(this, 'Accessibility:ScrollBackward', false);

These observers also need to removed in _disable.
Comment 6 User image Ryan VanderMeulen [:RyanVM] 2015-08-23 14:36:36 PDT
https://hg.mozilla.org/mozilla-central/rev/581329d6602b

Note You need to log in before you can comment on or make changes to this bug.