Closed Bug 1182348 (englishNZ-keyboard) Opened 7 years ago Closed 4 years ago

Create English (NZ) layout

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: ajones, Unassigned)

References

Details

Steps to reproduce:

* Settings -> Language -> English (GB)
* Open text message app
* Click on Message
* Type Harbour then press space

Expected results:

Should show Harbour

Actual results

Barbour.
Component: Gaia::L10n → Gaia::Keyboard
For those who don't know this - New Zealand and Australia use American keyboards (where shift-3 gives a # symbol, not a £ symbol) but British spelling. The choice of keyboard therefore should not affect the language variant.
Looks like we only have English (US) and English (GB) layouts, thus We need to create English (NZ) layout based on the description given in comment #1.
Summary: Keyboard doesn't speak the Queen's English → Create English (NZ) layout
I'd expect the layout to be independent of the dictionary, at least for English.
It is. We will use current en-GB dictionary for word prediction/autocorrect features and can copy/paste and adapt the en-US layout.
(In reply to Théo Chevalier [:tchevalier] from comment #4)
> It is. We will use current en-GB dictionary for word prediction/autocorrect
> features and can copy/paste and adapt the en-US layout.

The point I'm trying to make here is that selecting English (GB) language needs to simply work with the default English keyboard. There is no such thing as an NZ or AU keyboard.
(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #5)
> (In reply to Théo Chevalier [:tchevalier] from comment #4)
> > It is. We will use current en-GB dictionary for word prediction/autocorrect
> > features and can copy/paste and adapt the en-US layout.
> 
> The point I'm trying to make here is that selecting English (GB) language
> needs to simply work with the default English keyboard. There is no such
> thing as an NZ or AU keyboard.

Sorry, did not understand that.

But still, if you want an American keyboard with a British dictionary, it has to be a new layout, even if it's just a plain copy/paste from current en-US layout. This actually already exists, it's the English (Africa) layout.

So, not sure what's best here, renaming this one in a way that will be obvious for everyone or just creating a new one.

Selecting English (GB) language will always enable English (GB) keyboard as default it's what is used in UK. We can, however, add more alternatives layouts in addition to English (GB).
(In reply to Théo Chevalier [:tchevalier] from comment #6)
> Selecting English (GB) language will always enable English (GB) keyboard as
> default it's what is used in UK. We can, however, add more alternatives
> layouts in addition to English (GB).

The fundamental problem is that selecting English (GB) doesn't let me type in English (GB). I noticed that the English (UK) keyboard isn't installed by default so that may be the cause of the problem.

It doesn't make sense to me to select the keyboard in order to select the language, especially when I've already selected the language elsewhere. The concept of selecting a keyboard is completely foreign to me.

I also noticed that the language is GB but the keyboard is UK. I don't know what that means for Northern Ireland.
(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #7)
> (In reply to Théo Chevalier [:tchevalier] from comment #6)
> > Selecting English (GB) language will always enable English (GB) keyboard as
> > default it's what is used in UK. We can, however, add more alternatives
> > layouts in addition to English (GB).
> 
> The fundamental problem is that selecting English (GB) doesn't let me type
> in English (GB). I noticed that the English (UK) keyboard isn't installed by
> default so that may be the cause of the problem.
> 
> It doesn't make sense to me to select the keyboard in order to select the
> language, especially when I've already selected the language elsewhere. The
> concept of selecting a keyboard is completely foreign to me.
> 
> I also noticed that the language is GB but the keyboard is UK. I don't know
> what that means for Northern Ireland.

All the layouts can't be installed by default, that's why starting with Firefox OS 2.5 you can download them from Settings when they are not built-in. When you switch between locales, keyboards associated to the locale are enabled. Unfortunately this doesn't work atm for downloaded keyboards (bug 1184342).

The mismatch in en-GB keyboard naming should be fixed in bug 1182348.
(In reply to Théo Chevalier [:tchevalier] from comment #8)
> All the layouts can't be installed by default, that's why starting with
> Firefox OS 2.5 you can download them from Settings when they are not
> built-in. When you switch between locales, keyboards associated to the
> locale are enabled. Unfortunately this doesn't work atm for downloaded
> keyboards (bug 1184342).

Fixing bug 1184342 gets us pretty close then.
Alias: englishNZ-keyboard
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.