Closed Bug 1182957 Opened 5 years ago Closed 5 years ago

WIN Explorer file properties details wrongly show SeaMonkey 2.35

Categories

(SeaMonkey :: Build Config, defect)

SeaMonkey 2.36 Branch
Unspecified
Windows 7
defect
Not set
trivial

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: RainerBielefeldNG, Assigned: adriank)

References

Details

I found a hint concerning this problem here <https://blog.seamonkey-project.org/2015/06/16/first-win32-seamonkey-2-35-nightly-build-available/#comment-400>

Steps how to reproduce with DE SeaMonkey 2.36  (Windows NT 6.1; WOW64; rv:39.0 Beta-nightly by Adrian Kalla)  Gecko/20100101 Build 20150711180559 (Classic Theme) on German WIN7 64bit:

0. unzip seamonkey-2.36.de.win32.installer.exe (2015-07-11 23:44) from  <https://l10n.mozilla-community.org/~akalla/unofficial/seamonkey/nightly/latest-comm-release-windows32/> on HDD
1. Launch seamonkey.exe from subfolder "core"
2. Menu 'Help → About'
   » Shows SM 2.36
3. In subfolder "Core: 'rightclick "seamonkey.exe' → properties → Details'
   But: Shows "Product version 2.35"

a) This problem might be limited to this particular build, I will do 
   some more tests
b) Seems to be a very limited problem: 
   <https://l10n.mozilla-community.org/~akalla/unofficial/seamonkey/nightly/latest-comm-release-windows64/> seamonkey-2.36.de.win64.installer.exe 2015-07-09 07:41 does not show the problem.
Version   SeaMonkey.exe Build

2.35-32   38.0.6.5645   20150616034436  38.0.6 inside
2.35-64   38.0.6.5644   20150615204754  38.0.6 inside

2.36-32   38.0.6.5645   20150711180559  39.0.1 inside
2.36-64   39.0.1.5667   20150708210945  39.0.1 inside

2.38a2-32 41.0.0.5668   20150709001153  41.0a2 inside
2.39a1-32 42.0.0.5666   20150707001452  42.0a1 inside
I think that maybe something has gone terribly wrong and instead of pulling from mozilla-central there was a pull from mozilla-esr38 - so the win32 2.36 builds maybe in fact partially based on Gecko 38...

Unfortunately, I don't think that I'll manage to investigate this and make new builds before the weekend...
Assignee: nobody → akalla
Blocks: SM2.35
I’m in the process of fixing this. It seems like without completely deleting my workspace, the exe files will pretend to have a wrong Gecko version. Even removing the objdir seems to be not enough...

The 64 bit builds are already fixed, the 32 bit builds should be fixed tomorrow.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Version   SeaMonkey.exe Build

2.37-32   40.0.2.5706   20150816220730
2.37-64   40.0.2.5706   20150816073637

2.38-32   41.0.0.5706   20150816230519
2.38-64   41.0.0.5705   20150815115644

Thanks Adrian.
You need to log in before you can comment on or make changes to this bug.