Serious bug - Thunderbird recipient can be the wrong person!

RESOLVED DUPLICATE of bug 1152517

Status

RESOLVED DUPLICATE of bug 1152517
3 years ago
3 years ago

People

(Reporter: jan, Unassigned)

Tracking

38 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.132 Safari/537.36

Steps to reproduce:

Tried to send a message to one person but if the cursor highlights another recipient beofre sending the message it can go to that person by mistake.This can be highly embarrassing or worse if sensitive information gets to the wrong person.


Actual results:

Several times I have accidentally sent a message to the wrong person because I didn't notice that the recipient address had changed. I've made this mistake more than once when I'm in a hurry and not paying attention, so we have disabled the autocomplete, and added a link to my contact list as a work-around. That avoids the problem, but it's not as easy as the autocomplete was.

This is quite a serious bug, as it has the potential of sending sensitive or embarrassing messages to the wrong people. I'm a parenting counselor, and often send messages about personal matters to clients. Sending a message about a client's problems to someone who may know her could be the start of a lawsuit!


Expected results:

The recipient address that is originally selected should stay there!

Updated

3 years ago
Group: core-security
jan, you're perfectly right with your assessment of the severity of this bug, sorry for the annoyance caused. I've been at the forefront of advocating for a fast fix, and Magnus is currently working on it in bug 1152517. We'll land the fix asap.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1152517
You need to log in before you can comment on or make changes to this bug.