Closed Bug 1183240 Opened 5 years ago Closed 5 years ago

Update label copy on for Do Not Track setting in About:Preferences

Categories

(Firefox :: General, defect, P1)

defect
Points:
2

Tracking

()

VERIFIED FIXED
Firefox 42
Iteration:
42.2 - Jul 27
Tracking Status
firefox42 --- verified

People

(Reporter: agrigas, Assigned: past)

References

Details

(Whiteboard: [fxprivacy] [campaign])

User Story

To better distinguish the new Tracking Protection pref from Do Not Track, we intend to improve the label for Do Not Track.

Attachments

(2 files)

No description provided.
User Story: (updated)
Attached image DNTlabel.png
Attaching a screenshot of the copy we'd change (first checkbox). We'll mention DNT explicitly bc in user research, users didn't understand the difference between "telling" websites not to track and preventing websites from tracking. 

I find someone from priv/sec who can help review our final string change here.
Flags: qe-verify?
Flags: firefox-backlog?
Flags: qe-verify?
Flags: qe-verify-
Flags: firefox-backlog?
Flags: firefox-backlog+
Priority: -- → P1
Rank: 1
Depends on: 1179850
Assignee: nobody → past
Status: NEW → ASSIGNED
Iteration: --- → 42.2 - Jul 27
Points: --- → 2
Whiteboard: [fxprivacy] → [fxprivacy] [blocked on copy]
Final copy:
“Request that sites not track you.” Learn More

“Stop sites from tracking you in Private Windows." Learn More
Whiteboard: [fxprivacy] [blocked on copy] → [fxprivacy]
Whiteboard: [fxprivacy] → [fxprivacy] [campaign]
(In reply to agrigas from comment #2)
> Final copy:
> “Request that sites not track you.” Learn More
> 
> “Stop sites from tracking you in Private Windows." Learn More

Should I also change the string for the normal mode tracking protection?

 "Prevent sites from tracking me" -> "Stop sites from tracking you"

Also, I assume that we don't want the period at the end of the string per bug 1175920 comment 5 (and 9), right?
Flags: needinfo?(agrigas)
Here is a patch with the assumption that the response to my questions in comment 3 is "yes to both". I've also took the opportunity to fix a glitch in the alignment of the "Learn more" links in Linux that wasn't happening in OS X and Windows.
Attachment #8637094 - Flags: review?(jaws)
Hm, I just saw bug 1183795 and it appears that Javaun had a different idea about the normal mode TP label. Javaun, can you confirm what is the desired outcome for that string so I can land it as part of this bug?
Flags: needinfo?(jmoradi)
(In reply to Panos Astithas [:past] from comment #4)
> Created attachment 8637094 [details] [diff] [review]
> Update label copy on for Do Not Track setting in About:Preferences
> 
> Here is a patch with the assumption that the response to my questions in
> comment 3 is "yes to both". I've also took the opportunity to fix a glitch
> in the alignment of the "Learn more" links in Linux that wasn't happening in
> OS X and Windows.

I would make the DNT copy the same at least even if the other two are different. I never saw that other bug so we can chat with Javaun in standup...
Flags: needinfo?(agrigas)
We discussed it at the standup today and what's in the patch is what we want, so this is ready for review.
Flags: needinfo?(jmoradi)
Duplicate of this bug: 1183795
Ugh, trying to land this I got a conflict that pointed me to bug 1184188 and then the recent discussion in bug 1175920 that I had missed. I'm leaving the period in to not stir any more controversy over this.
https://hg.mozilla.org/mozilla-central/rev/4237000fd824
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 42
Verified as fixed using the following environment:

FF 42
Build Id: 20150805030208
OS: Win 7 x64, Ubuntu 14.04 x64, Mac OS X 10.10
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.