Closed Bug 1183818 Opened 4 years ago Closed 3 years ago

Address test failures with XRender disabled

Categories

(Core :: Graphics, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1180942

People

(Reporter: acomminos, Assigned: acomminos)

References

Details

(Whiteboard: [gfx-noted])

Attachments

(3 files)

Currently, quite a few tests fail on the tryserver with XRender disabled:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=724329bdccaf

These should be addressed.
Assignee: nobody → acomminos
Status: NEW → ASSIGNED
Depends on: 1183820
Many reftest differences appear to be caused by the fallback implementation of cairo_fill (as used by XLib) using bentley–ottmann trapezoid tessellation to fill paths, whereas cairo's image surface backend prefers its own scanline-based spans implementation first.
These patches fix test failures with XRender disabled by default (there's no way AFAIK to get GfxInfo in  WPT reftest). mochitest-bc3 still fails however with:

> INFO TEST-UNEXPECTED-FAIL | image/test/browser/browser_bug666317.js | Image should initially be decoded. -
Duplicate of this bug: 1182186
Andrew, are you still working on this?
Flags: needinfo?(andrew)
Whiteboard: [gfx-noted]
Nope, dupe of bug 1180942.
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Flags: needinfo?(andrew)
Resolution: --- → DUPLICATE
Duplicate of bug: 1180942
You need to log in before you can comment on or make changes to this bug.