2,500 instances of "'!editorRectEvent.mSucceeded'" emitted from widget/ContentCache.cpp during linux64 debug testing

RESOLVED DUPLICATE of bug 1183873

Status

()

defect
RESOLVED DUPLICATE of bug 1183873
4 years ago
4 years ago

People

(Reporter: erahm, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox42 affected)

Details

+++ This bug was initially created as a clone of Bug #1183873 +++

> 2491 [NNNNN] WARNING: '!editorRectEvent.mSucceeded', file widget/ContentCache.cpp, line 256

This is most likely related to bug 1183873.

This warning [1], introduced in bug 1166436 patch 9, shows up in the following test suites:

> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-browser-chrome-3-bm118-tests1-linux64-build0.txt:1013
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-browser-chrome-2-bm67-tests1-linux64-build0.txt:804
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-browser-chrome-1-bm53-tests1-linux64-build0.txt:483
> mozilla-central_ubuntu64_vm-debug_test-mochitest-1-bm117-tests1-linux64-build1.txt:108
> mozilla-central_ubuntu64_vm-debug_test-mochitest-browser-chrome-2-bm117-tests1-linux64-build8.txt:31
> mozilla-central_ubuntu64_vm-debug_test-mochitest-other-bm53-tests1-linux64-build0.txt:14
> mozilla-central_ubuntu64_vm-debug_test-mochitest-2-bm67-tests1-linux64-build1.txt:11
> mozilla-central_ubuntu64_vm-debug_test-mochitest-browser-chrome-3-bm122-tests1-linux64-build17.txt:10
> mozilla-central_ubuntu64_vm-debug_test-mochitest-5-bm115-tests1-linux64-build29.txt:7
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-1-bm123-tests1-linux64-build25.txt:3
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-5-bm52-tests1-linux64-build2.txt:2
> mozilla-central_ubuntu64_vm-debug_test-reftest-e10s-2-bm123-tests1-linux64-build2.txt:1
> mozilla-central_ubuntu64_vm-debug_test-reftest-e10s-1-bm68-tests1-linux64-build0.txt:1
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-4-bm122-tests1-linux64-build12.txt:1
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-3-bm51-tests1-linux64-build0.txt:1
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-2-bm53-tests1-linux64-build12.txt:1

It shows up in 820 tests. A few of the most prevalent:

> 46 - browser/base/content/test/general/browser_domFullscreen_fullscreenMode.js
> 41 - browser/components/sessionstore/test/browser_formdata_cc.js
> 37 - dom/manifest/test/browser_ManifestObtainer_obtain.js
> 37 - browser/base/content/test/general/browser_pageInfo.js
> 36 - browser/components/sessionstore/test/browser_615394-SSWindowState_events.js
> 30 - browser/components/sessionstore/test/browser_522545.js
> 29 - browser/base/content/test/general/browser_bug553455.js
> 24 - browser/components/sessionstore/test/browser_595601-restore_hidden.js
> 19 - toolkit/modules/tests/browser/browser_RemotePageManager.js
> 19 - browser/components/sessionstore/test/browser_formdata_format.js

[1] https://hg.mozilla.org/mozilla-central/annotate/e786406bc683/widget/ContentCache.cpp#l256
Virtually all instances of '!editorRectEvent.mSucceeded' are followed by '!mContentCache.CacheEditorRect(this, &aIMENotification)' which makes sense as ' WARNING: '!editorRectEvent.mSucceeded'' comes from |CacheEditorRect| which then returns false.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1183873
You need to log in before you can comment on or make changes to this bug.