SMS app does not match incoming phone number to contact

RESOLVED DUPLICATE of bug 1114525

Status

RESOLVED DUPLICATE of bug 1114525
3 years ago
3 years ago

People

(Reporter: bkelly, Unassigned)

Tracking

({dogfood})

unspecified
dogfood

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [bzlite])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
User-Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

I recently received an SMS from a family member on my new foxfood phone.  Her number is in my contacts in dash form (xxx-xxx-xxxx).  The SMS did not have any dashes.  The SMS app did not match the incoming number to the contact entry.
QA Whiteboard: [foxfood-triage]
Component: Gaia::Feedback → Gaia::Contacts
Keywords: qawanted

Comment 1

3 years ago
Created attachment 8640990 [details]
Aries_v2.5.3gp

I can repro this bug on the latest Flame v2.2 & Flame KK 2.5, and Aries 2.5 by the following STR.
  
See attachments: Aries_v2.5.3gp and logcat_0726.txt
Rate: 6/6

My STR is:
Precondition: 
DUT has two contacts who have a same number, and one of the contact's number is in dash form.
1.Send an SMS from the number in dash form to the DUT.
2.Tap a notification of SMS on lockscreen.

Actual results: The SMS did not have any dashes, but the number in my contacts app is in dash form (xxx-xxx-xxxx). SMS app did not match the number to the contact entry.

Device: Aries KK 2.5(Affected)
Build ID               20150728035120
Gaia Revision          14e32276025b0310d3e89027320cf4b2a24cedfb
Gaia Date              2015-07-27 16:43:18
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/33dc8a83cfc0
Gecko Version          42.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150728.033538
Firmware Date          Tue Jul 28 03:35:46 UTC 2015
Bootloader             s1

Device: Flame KK 2.2(Affected)
Build ID               20150729152503
Gaia Revision          8f3749f875c5ed155ccbd630aa2ee4e8bc2a9400
Gaia Date              2015-07-29 14:28:57
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e2a82fd90bc5
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150729.185252
Firmware Date          Wed Jul 29 18:53:03 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK 2.5(Affected)
Build ID               20150729150205
Gaia Revision          088f350b39baf8f86c7c1161fd4be178ce822b7b
Gaia Date              2015-07-29 15:33:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/62cd40885e93
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150729.183952
Firmware Date          Wed Jul 29 18:40:04 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Comment 2

3 years ago
Created attachment 8640992 [details]
logcat_0726.txt

Updated

3 years ago
QA Whiteboard: [foxfood-triage] → [foxfood-triage], [MGSEI-Triage+]
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Keywords: qawanted
I know Contacts and Dialer use SimplePhoneMatcher to perform this kind of look up. I don't see any use of this class in SMS. How do you search for a contact, is it with mozContact?
Flags: needinfo?(felash)
Yes, we have code at [1] that we use throughout the application, and that uses the mozContacts API.

I'm really surprised by this issue as this should generally work. And actually it seems to work for me locally.

[1] https://github.com/mozilla-b2g/gaia/blob/master/apps/sms/views/shared/js/contacts.js

I also don't understand the video from comment 1: we can clearly see in the Contacts app (at the start of the video) that this contact does not have any name: the phone number is displayed in the title.


Ben, can you please share how you imported this phone number? Also would it be possible for you to share your contacts db, possibly privately? I'd like to see how the contact itself is stored (especially its indices). Thanks !
Flags: needinfo?(felash) → needinfo?(bkelly)
(Reporter)

Comment 5

3 years ago
I imported the contact using the google import feature in contacts.

Maybe its because my contact info has:

  (###)-###-####

While the ril provided a format like this to SMS:

  +1##########

Is the matching code smart enough to realize +1 is my international code?
Flags: needinfo?(bkelly)
Oh, in that case, that's bug 877956.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 877956
(In reply to Ben Kelly [:bkelly] from comment #5)
> I imported the contact using the google import feature in contacts.
> 
> Maybe its because my contact info has:
> 
>   (###)-###-####
> 
> While the ril provided a format like this to SMS:
> 
>   +1##########
> 
> Is the matching code smart enough to realize +1 is my international code?

Yes it is :)

Did you import your Contact info while you had no SIM, or if the SIM was not connected, or in roaming condition ?

This is a case where the index in DOM:Contacts is incorrect (in my opinion) but it never bothered someone enough to fix it.
Duplicate of bug: 1114525
For questions from comment 7.
Flags: needinfo?(bkelly)
(Reporter)

Comment 10

3 years ago
(In reply to Julien Wajsberg [:julienw] from comment #7)
> Did you import your Contact info while you had no SIM, or if the SIM was not
> connected, or in roaming condition ?

Roaming.  I was in whistler when I got the phone and set it up.
Flags: needinfo?(bkelly)
OK.

So you can likely fix it for you by reimporting now that you're not in roaming condition anymore.
You need to log in before you can comment on or make changes to this bug.