Closed Bug 1184132 Opened 7 years ago Closed 7 years ago

Reader Mode fails to display local files

Categories

(Toolkit :: Reader Mode, defect)

39 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1166829

People

(Reporter: moz, Unassigned)

Details

Attachments

(1 file)

Attached file test.html
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150708165822

Steps to reproduce:

I started firefox. I opened a html file stored locally on my computer. See attachment for a minimal test file. I clicked on the reader button in urlbar.


Actual results:

Firefox went to a about:reader?url=file:///home/ … URL and immediately forwarded to about:blank. The reader view does not seem to work for this file. There is no output in web inspector console or to stdout/stderr.


Expected results:

about:reader should work for local files too.
Confirmed, Reader mode displays blabk page when the file is loaded locally
Component: Untriaged → Reader Mode
Product: Firefox → Toolkit
Summary: about:reader fails to display local files → Reader Mode fails to display local files
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1166829
You need to log in before you can comment on or make changes to this bug.