Closed Bug 1184141 Opened 7 years ago Closed 7 years ago

In-page filter-bar options are misaligned

Categories

(Marketplace Graveyard :: Consumer Pages, defect)

Avenir
Unspecified
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
2015-07-21

People

(Reporter: vvalentina, Assigned: trishul.goel, Mentored)

References

Details

(Whiteboard: [good first bug])

Attachments

(1 file)

46 bytes, text/x-github-pull-request
Details | Review
Steps to reproduce:
1. Load MP-dev app on your FF OS device
2. Go to any page where the in-page filter bar is available
3. Open the bar drop-down list

Expected results:
There are no display or layout issues.

Actual results:
The options are misaligned.

Notes/Issues:
Verified on FF OS 2.0 (Flame). Issue is reproduced on MP-dev.
Screenshot for this issue: http://screencast.com/t/qVBCKLzAjyVY
This is a regression from bug 1182297 which added padding for the blue platform selector. The update there was for all <mkt-select> elements and it looks like the content filter <mkt-select> had styles just for itself. Those styles probably need to be removed now.
Mentor: mstriemer
Whiteboard: [good first bug]
I was trying to fix this, but how to reproduce the mow dropdown on web.
Attached file Pull Request
Just removed the extra padding given in .content-filter mkt-selected
Thanks.
https://github.com/tsl143/fireplace/commit/75ca4f0f883439b2036c6bda36ec26877e86634d

Make sure you have `meowEnabled: true` set in your src/media/js/settings_local.js file to get the mow dropdown. You'll also have to open the site in Chrome emulator mode with a mobile device set, use a user agent switcher addon in Firefox or point your mobile device at your local machine. Feel free to ping me on IRC or send me an email if you need help with this next time.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Assignee: nobody → trishul.goel
Verified as fixed on MP-dev FF OS 2.0 (Flame)
Postfix screenshot: http://screencast.com/t/8oKvgjpVF
Closing bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.