If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Dialer] Device is unable to make outbound or answer inbound calls.

VERIFIED FIXED

Status

Firefox OS
RIL
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: Marty, Unassigned)

Tracking

({regression, smoketest})

unspecified
ARM
Gonk (Firefox OS)
regression, smoketest
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master verified)

Details

(Whiteboard: [2.5-Daily-Testing][Spark][fromAutomation])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8634143 [details]
logcat-dialer.txt

Description:
If the user attempts to make an outbound call, the first time they tap the 'send' button, nothing will happen, and the second time, the device will display the following error message: "Unable to make a phone call now Cannot make a call. If you are already dialing, please hang up first."

When receiving an inbound call, the device will ring, but attempting to answer the call will result in the user seeing the in-call UI while the phone continues ringing.

Repro Steps:
1) Update an Aries to 20150715083340
2) Open the dialer app
3) Enter a phone number and tap 'Send'
4) If a call isn't made, tap 'Send' again.

Actual:
The device will not make an outbound call

Expected:
The device makes an outbound call properly

Environmental Variables:
Device: Aries 2.5
Build ID: 20150715083340
Gaia: c6ef08964711f461a8e6326eae911789d1ec220c
Gecko: c95ebeebbc5d
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Repro frequency: 10/10
See attached:logcat
(Reporter)

Comment 1

2 years ago
This issue DOES occur on Flame 2.5
The device was unable to answer or make calls about 50% of the time on a fresh flash, but will occur 100% of the time after rebooting the device.

Environmental Variables:
Device: Flame 2.5
Build ID: 20150715010202
Gaia: c6ef08964711f461a8e6326eae911789d1ec220c
Gecko: c95ebeebbc5d
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 42.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

-----------------------------------------------------------------------

This issue does NOT occur on Flame 2.2 builds
The device makes an outbound call properly

Environmental Variables:
Device: Flame 2.2
Build ID: 20150715002506
Gaia: 84d0c76370dcd3d25813b00de55194730884355b
Gecko: a5db6d9850f6
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
Sanity blocker failure.

Requesting a window.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: qaurgent, regressionwindow-wanted
Isn't this because the base image of the device needs to be updated, like bug 1184124?

Updated

2 years ago
Blocks: 1184124
Last Working

Environmental Variables:
Device: Flame 2.5
Build ID: 20150714075333
Gaia: 8403f62b4a0528dcd826fdee43c022bee5071b29
Gecko: 25cc4676357b
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 42.0a1 (2.5)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0 

First Broken

Environmental Variables:
Device: Flame 2.5
Build ID: 20150714075727
Gaia: 8403f62b4a0528dcd826fdee43c022bee5071b29
Gecko: 46061230e77a
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 42.0a1 (2.5)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Gaia is the same

Gecko Pushlog
http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=25cc4676357b&tochange=46061230e77a

Looks like it was caused by bug 1171994
Flags: needinfo?(tzimmermann)
Keywords: qaurgent, regressionwindow-wanted
Blocks: 1171994
Blocks: 1174840
Fixed by backout
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(tzimmermann)
Resolution: --- → FIXED
(Reporter)

Comment 6

2 years ago
This issue is verified fixed on the latest Spark 2.5 build.
The device makes an outbound call properly

Environmental Variables:
Device: Aries 2.5
Build ID: 20150715181511
Gaia: c6ef08964711f461a8e6326eae911789d1ec220c
Gecko: 16e30af059b7
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-master: affected → verified
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
blocking-b2g: 2.5? → ---
Smoketest blocker.
blocking-b2g: --- → 2.5+
Moving this to the RIL component since it's not a dialer issue.
Component: Gaia::Dialer → RIL

Updated

2 years ago
Duplicate of this bug: 1184124

Updated

2 years ago
No longer blocks: 1184124
Bug 1184124 showed end-to-end automation also caught it.
Whiteboard: [2.5-Daily-Testing][Spark] → [2.5-Daily-Testing][Spark][fromAutomation]
You need to log in before you can comment on or make changes to this bug.