Closed Bug 1184239 Opened 6 years ago Closed 6 years ago

URL updates replace text while in editing mode

Categories

(Firefox for iOS :: Browser, defect)

All
iOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
fxios + ---

People

(Reporter: bnicholson, Assigned: bnicholson)

References

Details

(Keywords: regression)

Attachments

(1 file)

Another regression due to the URL bar unification. STR:
1) Go to https://people.mozilla.org/~bnicholson/test/redirect.html
2) Tap the URL bar before the page redirects
3) Type something
4) Wait

The text in the URL bar gets replaced with redirect URL.
Given all of the URL bar regressions, I think we should go back to how we did this before: use separate views for displaying and editing the page URL. Here's a mega-patch that does the following:
* Moves the `AutocompleteTextField` back into `URLBarView`.
* Creates an `inOverlayMode` variable to track whether we're in the panel overlay state. This is different from the `editing` state on a `UITextField` (we don't want to leave the mode just because the field loses focus). I decided to call it "overlay mode" instead of "editing mode" to avoid that confusion.
* Removed lots of unneeded code, and lots of mini-refactorings.

Overall, I'm pretty happy with the changes, but sorry I didn't split this up more. I can try breaking this down into smaller commits if needed.

**257 insertions(+), 398 deletions(-)** -- woohoo!
Assignee: nobody → bnicholson
Status: NEW → ASSIGNED
Attachment #8637028 - Flags: review?(wjohnston)
Note that this breaks some URL bar a11y (in particular, the a11y-enabled context menu that allows Paste & Go, etc.). I'll keep working on that, maybe as a separate follow-up if everything else looks OK.
When testing this out, note that this should fix all of the regressions blocking bug 1183690 except for the domain autocomplete flicker.
Comment on attachment 8637028 [details] [review]
Link to Github pull-request: https://github.com/mozilla/firefox-ios/pull/782

Seems to work pretty well. Most of my PR comments were nits and naming stuff. Lets get it in and test(/write tests!).
Attachment #8637028 - Flags: review?(wjohnston) → review+
Landed with comments addressed.

https://github.com/mozilla/firefox-ios/commit/c942a82f19d3a445d44845e5a95bb0400c652c76
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Depends on: 1187276
Depends on: 1191059
You need to log in before you can comment on or make changes to this bug.