mouseover erroneously displaced vertically if google maps canvas is not first element of body

RESOLVED DUPLICATE of bug 1175863

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1175863
3 years ago
3 years ago

People

(Reporter: Rich Flood, Unassigned)

Tracking

39 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8634317 [details]
google_test_fail.html

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150630154324

Steps to reproduce:

File google_test_fail.html provided to illustrate issue.  Move <div id="map-canvas"> below the next <div> to illustrate more correct behavior.


Actual results:

mouseover event fires at vertical position over map data item ~= vertical pixel dimension of preceding <div>.  When preceding <div> content height = 0px, map mouseover works correctly.


Expected results:

mouseover event should fire within map data item regardless of other page content.

Comment 1

3 years ago
It works as expected if used <script src="https://maps.googleapis.com/maps/api/js?v=3">
insted of <script src="https://maps.googleapis.com/maps/api/js?v=3.exp">
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1175863
You need to log in before you can comment on or make changes to this bug.