Stop using the term result-set and use push instead

RESOLVED FIXED

Status

P4
normal
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: mdoglio, Assigned: KWierso)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
We initially adopted the term result-set to indicate a set of changes from potentially more than one repository, but we have never had changes more than one repository so far. The term result-set is obscure and not intuitive, we should start using a simpler term like `push` or `change`.
(In reply to Mauro Doglio [:mdoglio] from comment #0)
> We initially adopted the term result-set to indicate a set of changes from
> potentially more than one repository, but we have never had changes more
> than one repository so far. The term result-set is obscure and not
> intuitive, we should start using a simpler term like `push` or `change`.

So I don't know the details of the result set model, but this might be something we'd want to take into account if we ever start tracking FirefoxOS performance results (which incorporate both Gaia and Gecko revision information).

Aside from that, changing the terminology everywhere would be a big change with a very marginal benefit. My vote is to leave things as they are.

Comment 2

3 years ago
(In reply to William Lachance (:wlach) from comment #1)
> Aside from that, changing the terminology everywhere would be a big change
> with a very marginal benefit. My vote is to leave things as they are.

One of the common complaints I've heard for ease of understanding Treeherder, is that in numerous places we use our own vocabulary rather than that used everywhere else in the organisation. At least in the UI parts, I very mush agree with using "push" instead of "resultset".

That's interesting to hear about the FirefoxOS perf use case - since that's the first I've heard of anything that would use the current over-engineered design we have at present (though it would still need a lot of changes to actually make it useable).
(In reply to Ed Morley [:emorley] from comment #2)
> (In reply to William Lachance (:wlach) from comment #1)
> > Aside from that, changing the terminology everywhere would be a big change
> > with a very marginal benefit. My vote is to leave things as they are.
> 
> One of the common complaints I've heard for ease of understanding
> Treeherder, is that in numerous places we use our own vocabulary rather than
> that used everywhere else in the organisation. At least in the UI parts, I
> very mush agree with using "push" instead of "resultset".

Yeah, just changing the UI should be fine (and much less difficult).

> That's interesting to hear about the FirefoxOS perf use case - since that's
> the first I've heard of anything that would use the current over-engineered
> design we have at present (though it would still need a lot of changes to
> actually make it useable).

Yeah, I suspect that's why this was designed in -- Jeads had to deal with the same issue in Datazilla.

Comment 4

3 years ago
It was designed in since at the original Treeherder design meeting myself and others requested it, since at the time we thought we'd have to handle B2G/gecko revisions separately, but that's since changed due to the pinned manifests.

Updated

3 years ago
Priority: -- → P4
Created attachment 8832807 [details] [review]
[treeherder] KWierso:1184510 > mozilla:master
(Assignee)

Comment 6

2 years ago
Comment on attachment 8832807 [details] [review]
[treeherder] KWierso:1184510 > mozilla:master

Dunno if it's worth changing this at this point, but these are all the places in html files that actually display the word "resultset" to the user changed to "push".
Attachment #8832807 - Flags: review?(emorley)

Comment 7

2 years ago
Comment on attachment 8832807 [details] [review]
[treeherder] KWierso:1184510 > mozilla:master

Looks good - thank you for doing this!

I think we'll also want to eventually update the API/backend etc too. Perhaps we can just open a separate bug for that, and make this one just for the UI?
Attachment #8832807 - Flags: review?(emorley) → review+

Updated

2 years ago
Assignee: nobody → wkocher
(Assignee)

Comment 8

2 years ago
The fun part is that "result-set" is used in a bunch of places in addition to "resultset".

Comment 9

2 years ago
Commit pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/7042a209702b819ff1488f8df2c350d92e6ef7e3
Bug 1184510 - Stop using the term 'resultset' for pushes (#2123) r=emorley
(Assignee)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Assignee)

Updated

2 years ago
Blocks: 1336272
Created attachment 8834112 [details] [review]
[treeherder] KWierso:resultsetv2 > mozilla:master
(Assignee)

Comment 12

2 years ago
Comment on attachment 8834112 [details] [review]
[treeherder] KWierso:resultsetv2 > mozilla:master

Question for one of the changes in the PR :)
Attachment #8834112 - Flags: review?(emorley)
Comment on attachment 8834112 [details] [review]
[treeherder] KWierso:resultsetv2 > mozilla:master

r+ with the changes mentioned in the PR.

Thank you for doing this :-)
Attachment #8834112 - Flags: review?(emorley) → review+

Comment 14

2 years ago
Commit pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/52f01979275dcd3a8f9460deecb5ed4fa48bfeb2
Bug 1184510 - Change some more UI references to 'result set' (#2137) r=emorley
(Assignee)

Updated

2 years ago
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.