Closed Bug 1184762 Opened 4 years ago Closed 4 years ago

Magnifying glass pops up on Mozilla SSO

Categories

(Firefox for Android :: General, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 42
Tracking Status
firefox42 --- fixed
fennec + ---

People

(Reporter: blassey, Assigned: domivinc)

References

Details

Attachments

(1 file, 1 obsolete file)

This is a mobile site with big touch areas, there really shouldn't be any reason for the magnifying glass to show up. And when it does, it is just getting in the way.
Please, could you give the url of the page with the issue? 
And could you post the values used in about:config for: 
ui.mouse.radius.* 
ui.touch.radius.*
Flags: needinfo?(blassey.bugs)
http://mozilla.okta.com/
all the ui.*.radius.* prefs are their default values
Flags: needinfo?(blassey.bugs)
The issue comes from the implementation of Bug 1180811. 
It occurs every time a tap occurs on a clickable element.
It's not specific to your page.
I'm going to fix it.
Assignee: nobody → domivinc
I added a test before closing the zoomed view with animation. The animation should occur only if the zoomed view is visible.
Attachment #8635711 - Flags: review?(michael.l.comella)
Comment on attachment 8635711 [details] [diff] [review]
patch-17072015 1-Bug_1184762___Check_visibility_before_closing_with_animation__r_mcomella.patch

Review of attachment 8635711 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm, assuming comment 0 doesn't mean the magnifying glass pops up and stays there, but rather the magnifying glass appears and animates out of the frame on click.
Attachment #8635711 - Flags: review?(michael.l.comella) → review+
You should check out the review in bug 1184912 before landing because we might want to consolidate the efforts around where to check for visibility.
Test of visibility has been moved in stopZoomDisplay method in order to simplify the implementation of bug 1184912.
Attachment #8637136 - Flags: review?(michael.l.comella)
Blocks: 1184912
Attachment #8635711 - Attachment is obsolete: true
Duplicate of this bug: 1186383
Duplicate of this bug: 1186387
tracking-fennec: ? → +
Comment on attachment 8637136 [details] [diff] [review]
patch-20072015 1-Bug_1184762___Check_visibility_before_closing_with_animation__r_mcomella.patch

Review of attachment 8637136 [details] [diff] [review]:
-----------------------------------------------------------------

::: mobile/android/base/ZoomedView.java
@@ +501,5 @@
>          moveUsingGeckoPosition(leftFromGecko, topFromGecko);
>      }
>  
>      private void stopZoomDisplay(boolean withAnimation) {
> +        if (getVisibility() == View.VISIBLE) {

nit: I prefer early error-check returns over placing the whole code block in an if statement - I find it a bit easier to reason about. So...

if (getVisibility() != View.VISIBLE) {
  return;
}

// More code...
Attachment #8637136 - Flags: review?(michael.l.comella) → review+
https://hg.mozilla.org/mozilla-central/rev/f0bef6917e18
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 42
You need to log in before you can comment on or make changes to this bug.