[Browser][SHB] Taps on the Software Home Button will also trigger tap events in browser windows beneath the SHB.

VERIFIED FIXED in Firefox OS master

Status

VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Marty, Assigned: apastor)

Tracking

({regression})

unspecified
FxOS-S4 (07Aug)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master verified)

Details

(Whiteboard: [2.5-Daily-Testing][Spark][SHB-enabled][systemsfe], URL)

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8635365 [details]
browser-shb-logcat.txt

Description:
When the user taps the black bar for the Software Home Button, any links or tappable things below the bar will also be selected. This is most commonly seen when tapping the SHB to return to the homescreen, then returning to the browser window to find that the browser had selected a link and changed to a different web-page.

Repro Steps:
1) Update an Aries to 20150717125848
2) Connect to a WiFi or Cellular Data network and open the Browser app.
3) Perform a google search and view a search result page.
4) Scroll so that a search result link is underneath the SHB, then tap the SHB
5) Return to the browser window.

Actual:
Tapping on the SHB triggered the link, and the Browser is no longer at the search results after reopening.

Expected:
Tapping on the SHB should not trigger anything in the browser window. The Browser should still be at the search results.

Environmental Variables:
Device: Aries 2.5
Build ID: 20150717125848
Gaia: 77bc0d940bde2a5d2d4dfadfcccc6d8d77456d36
Gecko: 15155971639c
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Repro frequency: 10/10
See attached: Video (URL), Logcat
(Reporter)

Comment 1

3 years ago
This issue DOES occur on the latest Flame 2.5 build.
Tapping on the SHB triggers browser links beneath.

Environmental Variables:
Device: Flame 2.5
Build ID: 20150717010206
Gaia: 77bc0d940bde2a5d2d4dfadfcccc6d8d77456d36
Gecko: 8d262d1d0ae5
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 42.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

------------------------------------------------

This issue does NOT occur on Flame 2.2 builds.
The browser is not affected when tapping on the SHB.

Environmental Variables:
Device: Flame 2.2
Build ID: 20150715002506
Gaia: 84d0c76370dcd3d25813b00de55194730884355b
Gecko: a5db6d9850f6
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
Functional Regression for SHB support.

Requesting a window.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Keywords: regressionwindow-wanted
QA Contact: jmercado
This issue seems to have been caused by the changes for Bug 1172050.

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 2.5
BuildID: 20150609110802
Gaia: 0b5638a17239080b4163cd81656028b4127f02dc
Gecko: a422730764e5
Version: 41.0a1 (2.5) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

First Broken 
Environmental Variables:
Device: Flame 2.5
BuildID: 20150609112503
Gaia: 7d1c6d5f7d9b27b30393fd26b611ea5148088c09
Gecko: a94934fccdb2
Version: 41.0a1 (2.5) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Last Working gaia / First Broken gecko - Issue does NOT occur
Gaia: 0b5638a17239080b4163cd81656028b4127f02dc
Gecko: a94934fccdb2

First Broken gaia / Last Working gecko - Issue DOES occur
Gaia: 7d1c6d5f7d9b27b30393fd26b611ea5148088c09
Gecko: a422730764e5

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/0b5638a17239080b4163cd81656028b4127f02dc...7d1c6d5f7d9b27b30393fd26b611ea5148088c09
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
Alberto, can you take a look at this please? This might have been caused by the landing for bug 1172050.
Blocks: 1172050
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(apastor)
Created attachment 8635958 [details] [review]
[gaia] albertopq:1185010-shb-ut > mozilla-b2g:master
(Assignee)

Updated

3 years ago
Assignee: nobody → apastor
Flags: needinfo?(apastor)
(Assignee)

Updated

3 years ago
Attachment #8635958 - Flags: review?(mhenretty)
blocking-b2g: 2.5? → 2.5+
Comment on attachment 8635958 [details] [review]
[gaia] albertopq:1185010-shb-ut > mozilla-b2g:master

Thanks!
Attachment #8635958 - Flags: review?(mhenretty) → review+
(Assignee)

Comment 7

3 years ago
master: https://github.com/mozilla-b2g/gaia/commit/62955148918d5ca2d2d020c769411c22caf008b1
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
status-b2g-master: affected → fixed
Target Milestone: --- → FxOS-S4 (07Aug)
This bug has been verified as "pass" on the latest nightly build of Flame KK v2.5 and Aires KK 2.5 by the STR in comment 0.

Actual results: Tapping on the SHB will not trigger browser links beneath.
See attachment: verified_Flame_v2.5.3gp
Reproduce rate: 0/10


Device: Flame KK 2.5 (Pass)
Build ID               20150802150204
Gaia Revision          2ca27bbdd84526c6a3b198d9cf10f2caff1dadde
Gaia Date              2015-07-31 08:23:31
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/32712cd01159
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150802.183402
Firmware Date          Sun Aug  2 18:34:15 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5(Pass)
Build ID               20150801110932
Gaia Revision          2ca27bbdd84526c6a3b198d9cf10f2caff1dadde
Gaia Date              2015-07-31 08:23:31
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/32712cd01159
Gecko Version          42.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150801.105449
Firmware Date          Sat Aug  1 10:54:56 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
status-b2g-master: fixed → verified
Created attachment 8642251 [details]
verified_Flame_v2.5.3gp
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.