Closed Bug 1185090 Opened 4 years ago Closed 4 years ago

[Contacts] Cannot send MMS to email address from contact page.

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master verified)

VERIFIED FIXED
FxOS-S4 (07Aug)
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- verified

People

(Reporter: NicholasN, Assigned: fcampo)

References

()

Details

(Keywords: regression, Whiteboard: [NG Gaia Contacts][patch][2.5-Daily-Testing][Spark])

Attachments

(2 files)

Attached file logcat_mmstoemail.txt
Description:
The user adds a contact, enters a personal email address for them, and saves the contact. On the contact's page, there is a message icon next to the email address to send an MMS to that email. This button is non-functional when tapped.


Repro Steps:
1) Update a Aries to 20150717125848
2) Go to contacts, and add a new contact with an email address.
3) Open the saved contact, and tap the message (speech bubble) icon next to their email address.


Actual:
MMS to email button is not functional.


Expected:
MMS to email button brings user to Messages when tapped.


Notes:

Environmental Variables:
Device: Aries 2.5
Build ID: 20150717125848
Gaia: 77bc0d940bde2a5d2d4dfadfcccc6d8d77456d36
Gecko: 15155971639c
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0


Repro frequency: 5/5
See attached: video clip, logcat
Note: Sending an MMS to email from the Messages app works as expected, and sending an MMS to a phone number from Contacts also works. The issue seems to be specific to the MMS to email button in contacts.



This issue reproduces on Flame 2.5, but not on Flame 2.2

Flame 2.5

Actual Result:

MMS to email button is not functional.

Environmental Variables:
Device: Flame 2.5
BuildID: 20150717010206
Gaia: 77bc0d940bde2a5d2d4dfadfcccc6d8d77456d36
Gecko: 8d262d1d0ae5
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 42.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Flame 2.2

Actual result:

MMS to email button brings user to Messages.

Environmental Variables:
Device: Flame 2.2
BuildID: 20150717002506
Gaia: e1e6317f17a840b19af9dbb25f5a771d8d9fa161
Gecko: 418b2388edb0
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regression
Whiteboard: [2.5-Daily-Testing][Spark]
[Blocking Requested - why for this release]:
Functional regression.

This is very likely a duplicate to the core issue in bug 1183301.  Let's see if the regression window matches up with bug 1183301.
blocking-b2g: --- → 2.5?
Flags: needinfo?(pbylenga)
QA Contact: jthomas
Comms triage: Like Peter inferred, that's probably a dupe bug 1183301. Let's dupe it and verify it once bug 1183301 lands.
Status: NEW → RESOLVED
blocking-b2g: 2.5? → 2.5+
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1183301
This is still occurring. This was not fixed by the landing for bug 1183301 so reopening this issue.
Status: RESOLVED → REOPENED
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Keywords: verifyme
Resolution: DUPLICATE → ---
Requesting a window.
B2G Inbound Regression Window

Last Working
Environmental Variables:
Device: Flame 2.5
BuildID: 20150715015429
Gaia: f3bcc1a2bf5852e927d417e218c4d7f9025dd455
Gecko: f2109a6e223b
Version: 42.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

First Broken
Environmental Variables:
Device: Flame 2.5
BuildID: 20150714225232
Gaia: 82bbf7acb527f7ebf818e9b9d55692ef48ad895e
Gecko: 727fea90574b
Version: 42.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Last Working gaia / First Broken gecko - This issue DOES occur.
Gaia: f3bcc1a2bf5852e927d417e218c4d7f9025dd455
Gecko: 727fea90574b

Last Working gecko / First Broken gaia - This issue does NOT occur.
Gecko: f2109a6e223b
Gaia: 82bbf7acb527f7ebf818e9b9d55692ef48ad895e

B2G Inbound Pushlog: https://github.com/mozilla-b2g/gaia/compare/c6ef08964711f461a8e6326eae911789d1ec220c...b9968cdc4a1dee49848fed6159a59c378cea062d

This issue is most likely caused due to Bug 1178646
Blocks: 1178646
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Flags: needinfo?(ktucker) → needinfo?(ktucker)
Manuel, can you take a look at this please? This might have been caused by the landing for bug 1178646.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(b.mcb)
Whiteboard: [2.5-Daily-Testing][Spark] → [NG Gaia Contacts][2.5-Daily-Testing][Spark]
Target Milestone: --- → FxOS-S4 (07Aug)
Fernando will work on it, thanks!
Assignee: nobody → fernando.campo
Status: REOPENED → ASSIGNED
Flags: needinfo?(b.mcb)
Comment on attachment 8641114 [details] [review]
[gaia] fcampo:mms-to-email-1185090 > mozilla-b2g:master

small patch fixing regression (mms capabilities to the email buttons)
Attachment #8641114 - Flags: review?(borja.bugzilla)
Whiteboard: [NG Gaia Contacts][2.5-Daily-Testing][Spark] → [NG Gaia Contacts][patch][2.5-Daily-Testing][Spark]
Attachment #8641114 - Flags: review?(borja.bugzilla) → review+
merged on master - https://github.com/mozilla-b2g/gaia/commit/6d91a3d13cc2a2f4a1f05e4db1076ca31517f928
Status: ASSIGNED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
Tested in Flame with latest master build (8/5) and now it works as expected. Thanks a lot Fernando! 

Environmental Variables:
flame master (2.5 version)
Build ID: 20150805111547
Gecko: c282e7e
Gaia: b795c40
Platform version: 42.0a1
Verified fixed on today's Flame 2.5

Actual Result:

Tapping MMS to Email button brings user to Messages, and the MMS can be sent to the email address.

Environmental Variables:
Device: Flame 2.5
BuildID: 20150805030212
Gaia: c5425d9f1f5184731a59ed4bc99295
acbde30390
Gecko: f3b757156f69
Gonk: 41d3e221039d1c4486fc13ff26793a7a39226423
Version: 42.0a1 (Master)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
Status: RESOLVED → VERIFIED
Per comment 12 & comment 13, change the 'status-b2g-master:' as verified.
You need to log in before you can comment on or make changes to this bug.