Closed Bug 1185111 Opened 4 years ago Closed 4 years ago

Thunderbird update 38.1 breaks outgoing mail using SMTPS on Mac OS X 10.10.4.

Categories

(Thunderbird :: Untriaged, defect)

38 Branch
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1184488

People

(Reporter: poppell, Unassigned)

Details

(Keywords: regression, Whiteboard: [regression 38.0.1 -> 38.1])

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.134 Safari/537.36

Steps to reproduce:

After updating from Thunderbird 38.0.1 to 38.1, all outgoing mail for our university accounts ceased to send.  The server settings:
Incoming: 
IMAP, mailhost.mathcs.emory.edu, port 993, SSL/TLS, normal password, mathcs-netid

Outgoing: 
SMTP, smtps.service.emory.edu, port 465, SSL/TLS, normal password, university-netid

I am unable to send mail with version 38.1, however after downgrading back to 38.0.1 I am successfully able to send mail using SMTP.


Actual results:

Immediate error message saying "Sending of Message failed.
The message could not be sent because connecting to SMTP server SMTP.comcast.net failed.The server may be unavailable or is refusing SMTP connections. Please verify that your SMTP server setting is correct and try again, or else contact your network administrator."

Mail is never sent.



Expected results:

Mail is sent as usual.  (NOTE, this works after downgrading to 38.0.1)
If this only happens in version 38.1.0, it is probably related to the issues in bug 1184488. Please see the discussion there.
Keywords: regression
Whiteboard: [regression 38.0.1 -> 38.1]
Running openssl on this server:

root@v32-linux64-db8:/usr/src/openssl-1.0.2d# openssl s_client  -crlf -connect smtps.service.emory.edu:465 | grep "Server Temp Key"
depth=2 C = SE, O = AddTrust AB, OU = AddTrust External TTP Network, CN = AddTrust External CA Root
verify error:num=19:self signed certificate in certificate chain
139865746486928:error:14082174:SSL routines:ssl3_check_cert_and_algorithm:dh key too small:s3_clnt.c:3554:
Server Temp Key: DH, 512 bits
root@v32-linux64-db8:/usr/src/openssl-1.0.2d#

"Server Temp Key: DH, 512 bits" is Logjam ->bug 1184488
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1184488
You need to log in before you can comment on or make changes to this bug.