Closed Bug 1185156 Opened 6 years ago Closed 6 years ago

[Dialer] User is unable to hang up the phone when making 2 calls at once and the second call is still ringing

Categories

(Firefox OS Graveyard :: RIL, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.5+, b2g-v2.1 unaffected, b2g-v2.2 affected, b2g-master verified)

VERIFIED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.2 --- affected
b2g-master --- verified

People

(Reporter: AdamA, Assigned: aknow)

References

()

Details

(Keywords: regression, Whiteboard: [2.5-Daily-Testing][Spark])

Attachments

(3 files)

Attached file logcat
Description:
If the user is in a call and makes another call while in the first call they will be unable to hang up the phone while the second call is ringing.

Repro Steps:
1) Update a Aries to 20150717125848
2) Make a call
3) While in the call screen press the home button
4) Open dialer and make another call
5) Press the button to end the call
6) Observe

Actual:
The user hang up the second call while it is ringing

Expected:
It is expected that the user can end calls at any time

Environmental Variables:
Device: Aries 2.5 [Full Flash]
Build ID: 20150717125848
Gaia: 77bc0d940bde2a5d2d4dfadfcccc6d8d77456d36
Gecko: 15155971639c
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Repro frequency: 10/10
See attached: video clip(https://youtu.be/V8vBBA9jGXw), logcat
This issue DOES occur on Flame 2.5 and Flame 2.2.

Environmental Variables:
Device: Flame 2.5 [Full Flash]
BuildID: 20150717010206
Gaia: 77bc0d940bde2a5d2d4dfadfcccc6d8d77456d36
Gecko: 8d262d1d0ae5
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 42.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Device: Flame 2.2 [Full Flash]
BuildID: 20150717002506
Gaia: e1e6317f17a840b19af9dbb25f5a771d8d9fa161
Gecko: 418b2388edb0
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Result:
The user hang up the second call while it is ringing
-------------------------------------------------
This issue DOES NOT occur on Flame 2.1

Environmental Variables:
Device: Flame 2.1 [Full Flash]
BuildID: 20150717001205
Gaia: cc24cce17ab2ebf79f6505103da714fc65bc5ec1
Gecko: fe4c34c770e5
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Result:
The user is able to hang up the second call at all points.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regression
Whiteboard: [2.5-Daily-Testing][Spark]
[Blocking Requested - why for this release]:
Functional regression

Requesting a window.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: pcheng
Comms triage: Regression breaking the UI.
blocking-b2g: 2.5? → 2.5+
b2g-inbound regression window:

Last Working
Device: Flame
BuildID: 20150629232345
Gaia: 5997b406e77ea726fbd9047057a1c3504f6cd6d4
Gecko: a16f198045ae
Version: 42.0a1 (2.5 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

First Broken
Device: Flame
BuildID: 20150630030244
Gaia: 5997b406e77ea726fbd9047057a1c3504f6cd6d4
Gecko: 1c43b1df2084
Version: 42.0a1 (2.5 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Gaia is the same so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=a16f198045ae&tochange=1c43b1df2084

Caused by changes made in Bug 1174673.
Blocks: 1174673
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Szu-Yu, can you take a look at this please? This might have been caused by the work done on 1174673.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(szchen)
Flags: needinfo?(szchen)
Sorry for the late response.

The problem is that we get a failure from ril for request HANGUP_FORGROUND_RESUME_BACKGROUND when there are one held call and one ringing call.

If the remote party accept the 2nd call, i.e., one held and one connected, the request HANGUP_FORGROUND_RESUME_BACKGROUND works well.

So, from the above 2 observations, it indicates that a ringing call is not regarded as a foreground call. Therefore, to hangup the call, we should use the request HANGUP with the call index. Moreover, to achieve the same result we want in bug 1174673. The proper handling for this scenario is
... sending out two consecutive requests in gecko: (1) HANGUP (2) SWITCH_WAITING_OR_HOLDING_AND_ACTIVE
Assignee: nobody → szchen
Attachment #8639180 - Flags: review?(htsai)
Component: Gaia::Dialer → RIL
Comment on attachment 8639180 [details] [diff] [review]
Fix bug in resuming held call

Review of attachment 8639180 [details] [diff] [review]:
-----------------------------------------------------------------

Thank you.
Attachment #8639180 - Flags: review?(htsai) → review+
https://hg.mozilla.org/mozilla-central/rev/edf65201bdaf has been pushed into m-c for a while
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
This bug has been verified as "pass" on the latest build of Flame KK 2.5 and Aires KK 2.5 by the STR in comment 0.

Actual results: User is able to hang up the second call when the second call is still ringing.
See attachment: verified_FlameKK_v2.5.3gp
Reproduce rate: 0/10


Device: Flame KK 2.5 (Pass)
Build ID               20150825150204
Gaia Revision          a8a462ab783a5bbab508d3c29483cff260672e3c
Gaia Date              2015-08-25 04:21:06
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c46370eea81a9860ae77d1f0c7776c24e816138e
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150825.204529
Firmware Date          Tue Aug 25 20:45:45 EDT 2015
Bootloader             L1TC000118D0

Device: Aries KK 2.5(Pass)
Build ID               20150825220518
Gaia Revision          a8a462ab783a5bbab508d3c29483cff260672e3c
Gaia Date              2015-08-25 04:21:06
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c46370eea81a9860ae77d1f0c7776c24e816138e
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150825.212416
Firmware Date          Tue Aug 25 21:24:24 UTC 2015
Bootloader             s1
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.