[yosemite][Thunderbird] Simplified Chinese shows up in Traditional Chinese mode when saving an image (attachment)

RESOLVED FIXED in Thunderbird 43.0

Status

Thunderbird
Build Config
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Philip Chee, Assigned: Thomasy)

Tracking

Trunk
Thunderbird 43.0
x86
Mac OS X

Thunderbird Tracking Flags

(thunderbird40 wontfix, thunderbird41 fixed, thunderbird42 fixed, thunderbird43 fixed, thunderbird_esr38- affected)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
+++ This bug was initially created as a clone of Bug #1089363 +++

(From Bug 1089363 comment #47)
> Created attachment 8548547 [details]
> Thunderbird may be affected by this bug
> 
> I wonder if Thunderbird is affected by this bug?
> The attachment is the menu from Thunderbird. It shows the simplified Chinese.
> If it is affected, we need to open a new one.
https://bug1089363.bugzilla.mozilla.org/attachment.cgi?id=8548547

(From Bug 1089363 comment #0)
> Created attachment 8511644 [details]
> Screenshot https://bug1089363.bugzilla.mozilla.org/attachment.cgi?id=8511644
> 
> The language was in Traditional Chinese, but when the user look at an image,
> right-clicked and chose "Save as", some fields in the dialog were in
> Simplified Chinese.
IS this a regression?
Component: Installer → Build Config
Flags: needinfo?(philip.chee)
Summary: [yosemite][Thunderbird] Simplified Chinese shows up in Traditional Chinese mode when saving an image. → [yosemite][Thunderbird] Simplified Chinese shows up in Traditional Chinese mode when saving an image (attachment)

Comment 2

2 years ago
I think this is broken by some change from OS X 10.10, not an regression.
(Reporter)

Comment 3

2 years ago
(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #1)
> IS this a regression?

https://bugzilla.mozilla.org/show_bug.cgi?id=1089363#c12
OS X 10.10 and higher changed the way certain files are parsed. Or perhaps just more strict and we got away with it in the past.
Flags: needinfo?(philip.chee)

Comment 4

2 years ago
Should this bug be morphed into a request to uplift the patch from bug 1089363 to Thunderbird 38?

Comment 5

2 years ago
After looking at bug 1089363, that is mostly for browser, so we would have to port those changes to Thunderbird.
(Assignee)

Comment 6

2 years ago
Created attachment 8645348 [details] [diff] [review]
bug1185268_rev1.patch

Porting the patch according to comment 5 

Try server change-set
https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=7b0bb98a7e5a

Try server result
https://hg.mozilla.org/try-comm-central/rev/7b0bb98a7e5a
Assignee: nobody → thomas
Attachment #8645348 - Flags: review?(rkent)
(Assignee)

Comment 7

2 years ago
Created attachment 8645350 [details]
fixed_version_dialog.png

Comment 8

2 years ago
Comment on attachment 8645348 [details] [diff] [review]
bug1185268_rev1.patch

Philip Chee, could you review this and test the try-server build, since you are pushing for an uplift?

Magnus would be a better reviewer than I, but I'll try it if he does not have time.
Attachment #8645348 - Flags: review?(rkent)
Attachment #8645348 - Flags: review?(mkmelin+mozilla)
Attachment #8645348 - Flags: feedback?(philip.chee)

Updated

2 years ago
status-thunderbird_esr38: --- → affected
tracking-thunderbird_esr38: --- → +
(Reporter)

Comment 9

2 years ago
Comment on attachment 8645348 [details] [diff] [review]
bug1185268_rev1.patch

(In reply to Kent James (:rkent) from comment #8)

> Philip Chee, could you review this and test the try-server build, since you
> are pushing for an uplift?

1. I don't have an Apple. 2. L10n build configuration is a mystery to me. 3.

> Magnus would be a better reviewer than I, but I'll try it if he does not
> have time.
Jcranmer probably knows the build system better than anyone in comm-central.

Also see ewong's comment in the SeaMonkey version of this patch in https://bugzilla.mozilla.org/show_bug.cgi?id=1185270#c5
Attachment #8645348 - Flags: feedback?(philip.chee)

Comment 10

2 years ago
Comment on attachment 8645348 [details] [diff] [review]
bug1185268_rev1.patch

Review of attachment 8645348 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM, r=mkmelin
Attachment #8645348 - Flags: review?(mkmelin+mozilla) → review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed
http://hg.mozilla.org/comm-central/rev/8eb72461147a
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 43.0

Updated

2 years ago
tracking-thunderbird_esr38: + → 41+

Comment 12

2 years ago
Comment on attachment 8645348 [details] [diff] [review]
bug1185268_rev1.patch

https://hg.mozilla.org/releases/comm-aurora/rev/a10cac67957d
https://hg.mozilla.org/releases/comm-beta/rev/b1afb50fb6dd

I'm leaning toward not taking this in Thunderbird 38.3.0 and waiting until 38.4.0  Nobody seems to be pushing it very hard, and I don't understand the issues well enough to convince myself this is low risk.

If someone else wants to make the case for 38.3.0 there is still time. It should go in the next TB 41 beta.
Attachment #8645348 - Flags: approval-comm-esr38?
Attachment #8645348 - Flags: approval-comm-beta+
Attachment #8645348 - Flags: approval-comm-aurora+

Updated

2 years ago
status-thunderbird40: --- → wontfix
status-thunderbird41: --- → fixed
status-thunderbird42: --- → fixed
status-thunderbird43: --- → fixed
tracking-thunderbird_esr38: 41+ → 42+

Comment 13

2 years ago
This does not seem to be generating any known user issues, so no real reason to take the risk for esr38.
tracking-thunderbird_esr38: 42+ → -

Updated

2 years ago
Attachment #8645348 - Flags: approval-comm-esr38? → approval-comm-esr38-
You need to log in before you can comment on or make changes to this bug.