Toggling fullscreen mode causes Normal View with missing Window Decoration, Fullscreen View with superfluous Window Decoration

RESOLVED FIXED in seamonkey2.39

Status

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: moz, Assigned: neil)

Tracking

({regression})

SeaMonkey 2.38 Branch
seamonkey2.39
Unspecified
All

SeaMonkey Tracking Flags

(seamonkey2.38 fixed, seamonkey2.39 fixed)

Details

Attachments

(5 attachments, 2 obsolete attachments)

Reporter

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0 SeaMonkey/2.38a2
Build ID: 20150718013005

Steps to reproduce:

toggle fullscreen mode with F11 in browserwindow


Actual results:

Enter fullscreen mode maximizes window and hides window decoration and controls but leaves menubar and other toolbars untouched.
Leaving fullscreen mode restores window decoration and controls but hides menubar and other toolbars.

Restarting SeaMonkey while in normal mode restores correct behaviour, restarting while in fullscreen mode preserves broken status.

Happened first time after automatic upgrade of SeaMonkey on Aurora Channel to 2.38a2.


Expected results:

In fullscreen mode window controls and toolbars should be hiden in normal mode visible.

Comment 1

4 years ago
Posted image Screenshot Comparison (obsolete) —
This problem has been discussed at <de.comm.software.mozilla.nightly-builds> under "[SM Aurora] Chaos mit Vollbildmodus"

@reporter:
a) What exactly is the difference to "Bug 1138247 - Window decorations (close,
   minimize, and maximize buttons) are missing with lwtheming and fullscreen "?
b) Does the screenshot show your problem completely?
Flags: needinfo?(moz)

Comment 2

4 years ago
Posted image Screenshot Comparison 2 (obsolete) —
My first screenshot comparison was wrong, already switch to fullscreen mode looks wrong.

The longer I think about that the more I doubt that Bug 1138247 is INVALID. I doubt that it is common sense to have OS Windows frame and window size buttons in full screen mode.
Attachment #8635777 - Attachment is obsolete: true
Flags: needinfo?(moz)

Comment 3

4 years ago
> <therube>	more then once now, F11 does something funky ... hmm, in SeaMonkey 2.39a1 ATM,
>               & don't know if the same happens in SeaMonkey 2.33.1, nor if it might be extension related ...
>               but F11 does go into "full screen", overlaying the (Windows) Taskbar, but also displays full menu bars;
>                File | URLbar | Bookmarks bar | & tabs & status bar at the bottom, & then when you go out of fullscreen,
> <therube>	the status bar is gone, File menu items are gone, URL bar & tabs are there.
> <therube>	Alt-V does bring up the View menu & it does show everything to be selected as expected
> <therube>	existing or new window display as expected - until they've been F11'd at which time they're screwed up
> <therube>	ditto in a different Profile
> <therube>	on restart its fine
> <therube>	SeaMonkey 2.331 is fine... wonder if I have "fuller screen" or something like that...?
> <therube>	no.
> <therube>	safe mode, likewise affected
> <therube>	& likewise in a new Profile. also note that when you come out of Full Screen, you're set to "small" icons
> <therube>	the 2.38a1 build i have does likewise
> <therube>	SeaMonkey 2.35 (contrib) works as expected

> <RattyAway>	therube: NeilAway said that recently some backend changes broke our full screen code
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

4 years ago
Three screenshots, scaled down to 800x600. A fresh browser window before playing with F11 in bild1.png, the result of the first F11 in bild2.png and the result of the second F11 in bild3.png.

Subsequent F11 toggle between bild2.png and bild 3.png.

Comment 5

4 years ago
Posted image bild1.png

Comment 6

4 years ago
Posted image bild2.png

Comment 7

4 years ago
Posted image bild3.png

Comment 8

4 years ago
Oh, I forgot: SM-Trunk Linux x86_64
Reporter

Comment 9

4 years ago
(In reply to Rainer Bielefeld from comment #1)

> @reporter:
> a) What exactly is the difference to "Bug 1138247 - Window decorations
> (close,
>    minimize, and maximize buttons) are missing with lwtheming and fullscreen
> "?

bug 1138247 is completely different, this one here is not about missing window controls in fullscreen mode, I think that is ok and at least has been around since years, the new problem is that in fullscreen mode Toolbars etc are visible in normal mode hidden.

> b) Does the screenshot show your problem completely?

kind of, but only if you switch the labels :-) you confounded the two states in your screenshot collage

Comment 10

4 years ago
Regression window for SM-Trunk Linux x86_64
Last good: 2015-06-10 15:12:00 PDT   c-c:c352d4695e28 m-c:95afddf894e3
First bad: 2015-06-11 19:09:00 PDT   c-c:c352d4695e28 m-c:c2a414f8bd73
Keywords: regression

Comment 11

4 years ago
In reply to Susanne Jaeger from comment #9)
> you confounded the two states in your screenshot collage

No, I did not. But I fraudulently concealed a part of the problem ;-)
For details se neww screenshots (not showing new facts for you)!

REPRODUCIBLE with  SeaMonkey 2.38a1  (Windows NT 6.1; WOW64; rv:41.0 nightly by Philip Chee)  Gecko/20100101 Firefox/41.0 Build 20150620233542 (Classic Theme) on German WIN7 64bit

I tried to narrow down appearance:

Still ok
2.37a2   20150522012631
2.38a1   20150523065810
2.37a2   20150609235642

alreay broken
2.38a1   20150620233542

So it seems that the problem appeared with a commit to 2.38 branch between 
20150523065810        and
20150620233542
Attachment #8635778 - Attachment is obsolete: true

Comment 12

4 years ago
c) not a specific <f11> problem, also visible with Keyboard shortcut <alt+v><f>
d) Launching 2.35 with the same profile heals the problem for 2.38 until next
   <f11>
e) FF 42.0a1 (2015-07-18) (WIN) is not affected
OS: Unspecified → All
Summary: Toggling fullscreen mode with F11 broken → Toggling fullscreen mode causes Normal View with missing Window Decoration, Fullscreen View with superfluous Window Decoration

Comment 13

4 years ago
f) I did not find a sure DUP in <https://bugzilla.mozilla.org/buglist.cgi?cmdtype=dorem&remaction=run&namedcmd=DUPs1185329&sharer_id=41036&list_id=12404439>, but  there were some hacks in FF since 2015-05-23
Assignee

Comment 14

4 years ago
(In reply to Rainer Bielefeld from comment #11)
> So it seems that the problem appeared with a commit to 2.38 branch between 
> 20150523065810        and
> 20150620233542

Bug 1161802 made it so that the full screen event  gets sent after the window becomes full screen, whereas it used to get sent before (so the window wasn't full screen yet).
Assignee

Comment 15

4 years ago
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #8636227 - Flags: review?(philip.chee)

Comment 16

4 years ago
Comment on attachment 8636227 [details] [diff] [review]
Proposed patch

Yay!
Attachment #8636227 - Flags: review?(philip.chee) → review+
Assignee

Comment 17

4 years ago
Pushed comm-central changeset d8261c906607.

(This needs to be uplifted, right?)
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.39

Comment 18

4 years ago
Comment on attachment 8636227 [details] [diff] [review]
Proposed patch

[Triage Comment]
a=me for SM2.38
Attachment #8636227 - Flags: approval-comm-aurora+
You need to log in before you can comment on or make changes to this bug.