media.play-stand-alone not honoured

RESOLVED INVALID

Status

()

RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: cpearce, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
When media.play-stand-alone is false, we are supposed to not play videos when opened in a video document; we should either defer them to the default handle for that mime-type, or download them.

Must be something wrong with DecoderTraits::IsSupportedInVideoDocument or whatever's calling it.
(Reporter)

Updated

3 years ago
See Also: → bug 1185782
(Reporter)

Comment 1

3 years ago
This seems to be caused by some other plugins I have installed, either QuickTime or VLC Web Player being registered to handle the video mime types. We behave as expected if these are not installed.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.