Regression: Send Later Crashes

VERIFIED DUPLICATE of bug 10774

Status

P3
major
VERIFIED DUPLICATE of bug 10774
20 years ago
10 years ago

People

(Reporter: esther, Assigned: hyatt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
Using 19990813 build on win98 and nt4.0 Send Later crashes.  Single pop account
or multiple accounts.  Will check other platforms when we get them.  Talkback
incident 12391707

1. Launch Messenger
2. Select New Message  Address it and type something in subject and body
3. Select Send Later from File menu
Crash


Call Stack:    (Signature = RDFElementImpl::RemoveAttribute 9f9616d2)
RDFElementImpl::RemoveAttribute
[d:\builds\seamonkey\mozilla\rdf\content\src\nsRDFElement.cpp, line 975]
nsMenuFrame::OpenMenu
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsMenuFrame.cpp, line 430]
nsMenuPopupFrame::DismissChain
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsMenuPopupFrame.cpp, line 539]
nsMenuFrame::Execute
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsMenuFrame.cpp, line 936]
nsMenuFrame::HandleEvent
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsMenuFrame.cpp, line 245]
PresShell::HandleEvent
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 1881]
nsView::HandleEvent
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 835]
nsView::HandleEvent
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 820]
nsViewManager::DispatchEvent
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1611]
HandleEvent
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 67]
nsWindow::DispatchEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 502]
nsWindow::DispatchWindowEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 523]
nsWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3273]
ChildWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3466]
nsWindow::ProcessMessage
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2529]
nsWindow::WindowProc
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 572]
KERNEL32.DLL + 0x363b (0xbff7363b)
KERNEL32.DLL + 0x242e7 (0xbff942e7)
0x00638bfe
Registers:
EAX:
00000000
EBX:
00000001
ECX:
605ce400
EDX:
0063f820
ESI:
07b8afa0
EDI:
00000000
ESP:
0063f808
EBP:
0063f818
EIP:
605bd294
cf PF af zf sf of IF df nt RF vm   IOPL: 0
CS:
0177
DS:
017f
SS:
017f
ES:
017f
FS:
1377
GS:
0000
(Reporter)

Updated

20 years ago
QA Contact: lchiang → esther
(Reporter)

Comment 1

20 years ago
Also happens on Mac and Linux with todays builds 19990813.
(Reporter)

Updated

19 years ago
OS: Windows 98 → All
Hardware: PC → All

Comment 2

19 years ago
*** Bug 11860 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Assignee: putterman → hyatt
Severity: critical → blocker
Whiteboard: [blocker]
Target Milestone: M9

Comment 3

19 years ago
reassigning to hyatt.  Apparently other menus crash also.  I haven't tried all
menus yet, but so far we know of at least two.  Maybe QA can try some other
ones.  I'm taking the liberty of setting this to M9 since it seems pretty
serious, please correct if you feel otherwise.

Comment 4

19 years ago
OK.  Some more investigation makes me think it's only happening on menu items
that dismiss the window, like Send Later, Exit, Close.  It's not as bad as I
thought.

Updated

19 years ago
Severity: blocker → major
Whiteboard: [blocker]

Comment 5

19 years ago
removing blocker status since after talking to QA we decided it's not really
blocking us.  however, this would be a good thing to have fixed for M9 since I
don't think we want to crash on these menu items.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 6

19 years ago
I have a fix in hand for this problem.  If chofmann approves, I'll land it...
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 7

19 years ago
*** This bug has been marked as a duplicate of 10774 ***

Comment 8

19 years ago
ok, checkin
(Reporter)

Comment 9

19 years ago
Using 19990815 build on win98 this scenario is working,  waiting for linux and
mac builds to test, then I will verify as duplicate

Comment 10

19 years ago
Linux (1999-08-16-08 M9)
Send Later works fine on Linux in this build.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 11

19 years ago
Using 19990816 build on Ninoschka's system this does not crash.  Will verify as
duplicate since I re-tested this scenario.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.