[Clock][Audio] Alarms and Timers do not make any sound, only vibrate

RESOLVED DUPLICATE of bug 1181982

Status

Firefox OS
Gaia::Clock
RESOLVED DUPLICATE of bug 1181982
2 years ago
2 years ago

People

(Reporter: Marty, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-master affected)

Details

(Whiteboard: [2.5-Daily-Testing][Spark], [dogfood-blocker])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8636631 [details]
logcat-alarm.txt

Description:
Regardless of the Audio Channel volume, ringing alarms and timers will not make any sound when they expire.

When the Alarm Audio channel is modified in Settings>Sound, the volume will play properly, but will not play during an actual alarm.

Repro Steps:
1) Update a Aries to 20150721140411
2) In Settings>Sound, increase the Alarm volume to maximum.
3) Open the Clock app and set an alarm for 1 minute in the future.

Actual:
The alarm activates, and the device vibrates, but there is no alarm sound.

Expected:
Alarm sound plays properly at the selected volume.

Environmental Variables:
Device: Aries 2.5
Build ID: 20150721140411
Gaia: 4fe0507781f3ed56c8ae5e66dd9489165d1ff68e
Gecko: d7a9e44717b7
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Repro frequency: 10/10
See attached: logcat
(Reporter)

Comment 1

2 years ago
This issue DOES occur on the latest Flame Nightly 2.5 build.
The alarm activates, and the device vibrates, but there is no alarm sound.

Environmental Variables:
Device: Flame 2.5
Build ID: 20150721010202
Gaia: 4fe0507781f3ed56c8ae5e66dd9489165d1ff68e
Gecko: 3a4bfa5d2d02
Gonk: 41d3e221039d1c4486fc13ff26793a7a39226423
Version: 42.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

--------------------------------------

This issue does NOT occur on yesterdays Flame Nightly 2.5 build.
Alarm sound plays properly at the selected volume.

Environmental Variables:
Device: Flame 2.5
Build ID: 20150720010206
Gaia: 3fac3ed7b8c887351098ffc677769ddc36abb3d0
Gecko: 202e9233d130
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 42.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
Functional issue that fails smoke tests and won't wake me up.

Requesting a window.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: qaurgent, regressionwindow-wanted
QA Contact: pcheng
Smoketest blocker.
blocking-b2g: 2.5? → 2.5+
Whiteboard: [2.5-Daily-Testing][Spark] → [2.5-Daily-Testing][Spark], [dogfood-blocker]
b2g-inbound regression window:

Last Working
Device: Flame
BuildID: 20150720073224
Gaia: a47e0c58dd1340a17be7cc96ccd90fcad15a922b
Gecko: f7d9b77a7afb
Version: 42.0a1 (2.5 Master) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

First Broken
Device: Flame
BuildID: 20150720074629
Gaia: a47e0c58dd1340a17be7cc96ccd90fcad15a922b
Gecko: e9b4a2b76fb3
Version: 42.0a1 (2.5 Master) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Gaia is the same so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=f7d9b77a7afb&tochange=e9b4a2b76fb3

Caused by changes made in Bug 1184055.
Blocks: 1184055
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qaurgent, regressionwindow-wanted
Alastor, can you take a look at this please? The landing for bug 1184055 seems to be the cause here. This is a smoke test blocker so we may need that landing backed out.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(alwu)
This issue would be solved by bug1181982, that is because we can't manage the sound of the attention window.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(alwu)
Resolution: --- → DUPLICATE
Duplicate of bug: 1181982
Duplicate of another smoketest blocker.
blocking-b2g: 2.5+ → ---
Keywords: smoketest
You need to log in before you can comment on or make changes to this bug.