bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

dash-player.com "Live Stream DVR" demo plays for a few seconds and then stalls, stuck rebuffering (syntax error?)

RESOLVED WORKSFORME

Status

()

Core
Audio/Video
P1
normal
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: cpeterson, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox41 affected, firefox42 verified)

Details

(URL)

(Reporter)

Description

3 years ago
@ Jean-Yves, does this look like a bug in the Bitmovin DASH player?


The following live stream plays for a few seconds in Firefox, but then gets stuck rebuffering with a loading spinner forever. The live stream plays correctly in Chrome, Safari, and IE.

http://www.dash-player.com/demo/live-streaming-dvr/

I see a "syntax error" message in the browser console, but the player continues to download .m4a and .m4v media segments

timeshift of 110 minutes live-streaming-dvr:1009:5
bitdash onPause:  Object { time: 702267.817666, timestamp: 1437506537310, type: "onPause" } live-streaming-dvr:1055:15
bitdash onPlaybackFinished:  Object { timestamp: 1437506537313, type: "onPlaybackFinished" } live-streaming-dvr:1058:14
GET XHR http://bitlivedemo-a.akamaihd.net/mpds/stream.php [HTTP/1.1 200 OK 1650ms]
bitdash 3.0.2 enterprise onReady:  Object { timestamp: 1437506538984, type: "onReady" } live-streaming-dvr:1042:1
bitdash onPlay:  Object { time: 0, timestamp: 1437506538990, type: "onPlay" } live-streaming-dvr:1050:15

syntax error live-streaming-dvr:1:1

GET XHR http://bitlivedemo-a.akamaihd.net/dash/250k/bitcodin-init.m4a [HTTP/1.1 200 OK 0ms]
GET XHR http://bitlivedemo-a.akamaihd.net/dash/250k/bitcodin-init.m4v
...
Flags: needinfo?(jyavenard)
(Reporter)

Comment 1

3 years ago
Daniel and Reinhard, Mozilla plans to enable MSE for all websites in Firefox 42 (testing now in the Firefox Nightly channel). Do you know the source of the "syntax error" message from this dash-player.com demo? This error message does not look like a JavaScript error that Firefox would generate.
Blocks: 778617
Flags: needinfo?(reinhard.grandl)
Flags: needinfo?(daniel.weinberger)
(Reporter)

Updated

3 years ago
Priority: -- → P1
(Reporter)

Comment 2

3 years ago
This bug may be related to bug 1131487 and bug 1137118, other "dash-player.com video stalls" bugs.
Summary: dash-player.com "Live Stream DVR" demo plays for a few seconds and then gets stuck rebuffering (syntax error?) → dash-player.com "Live Stream DVR" demo plays for a few seconds and then stalls, stuck rebuffering (syntax error?)
(Reporter)

Comment 3

3 years ago
I don't think the "syntax error" message is related to the stalling problem. I see the same error on other dash-player.com demo videos that do not stall, such as:

http://www.dash-player.com/demo/streaming-server-and-encoder-support/
can't reproduce the problem with the new MSE enabled.

All streams play fine for me now.
I'm not going to investigate the old MSE stack.
Flags: needinfo?(jyavenard)
we stall because no audio is appended. Reproduced twice in the same spot.

We have 38.41s worth of audio, playback stalls exactly at that point.

I get the same stall in Chrome at exactly the same point
(Reporter)

Comment 8

3 years ago
(In reply to Jean-Yves Avenard [:jya] from comment #5)
> can't reproduce the problem with the new MSE enabled.

This stall is 100% reproducible for me with Nightly 42 on OS X 10.10 and in a Windows 8.1 VM.
with the new MSE activated?
media.mediasource.format-reader set to true.

Note that the new MSE should be the default in tomorrow's nightly if all goes well.
(Reporter)

Comment 10

3 years ago
Sorry, I misunderstood. By "new MSE", I thought you meant the MSE clean-ups that you had already landed. I didn't know about the media.mediasource.format-reader pref. I can no longer reproduce the immediate stall when I set the pref to true.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox42: affected → verified
Flags: needinfo?(reinhard.grandl)
Flags: needinfo?(daniel.weinberger)
Resolution: --- → WORKSFORME
(In reply to Chris Peterson [:cpeterson] from comment #10)
> Sorry, I misunderstood. By "new MSE", I thought you meant the MSE clean-ups
> that you had already landed. I didn't know about the
> media.mediasource.format-reader pref. I can no longer reproduce the
> immediate stall when I set the pref to true.

This is the new MSE stack that I've been talking about for months :)

Feel free to play with it with that pref turned on... The more testing, the better.
You need to log in before you can comment on or make changes to this bug.