Last Comment Bug 1185611 - (mse-everywhere) Enable MSE for all websites (i.e. remove MSE whitelist)
(mse-everywhere)
: Enable MSE for all websites (i.e. remove MSE whitelist)
Status: RESOLVED FIXED
: dev-doc-needed
Product: Core
Classification: Components
Component: Audio/Video: Playback (show other bugs)
: unspecified
: Unspecified Unspecified
-- normal with 1 vote (vote)
: mozilla42
Assigned To: Jean-Yves Avenard [:jya]
:
: Anthony Jones (:kentuckyfriedtakahe, :k17e)
Mentors:
: 1125936 1173953 (view as bug list)
Depends on: 1197438 DASH-IF 1136050 1183196 1185886 1186136 1186149 1187136 1187143 1187542 1189204 1189899 1189987 1190530 1190970 1191202 1191220
Blocks: MSE 1143841 1197083
  Show dependency treegraph
 
Reported: 2015-07-20 11:06 PDT by Chris Peterson [:cpeterson]
Modified: 2016-02-08 12:13 PST (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
wontfix
wontfix
wontfix
fixed
42+


Attachments
[MSE] P1. Remove whitelist. (42.73 KB, patch)
2015-07-30 18:31 PDT, Jean-Yves Avenard [:jya]
kinetik: review+
Details | Diff | Splinter Review

Description User image Chris Peterson [:cpeterson] 2015-07-20 11:06:06 PDT
We plan to enable MSE for all websites in Nightly 42.
Comment 1 User image Chris Peterson [:cpeterson] 2015-07-20 11:06:56 PDT
*** Bug 1125936 has been marked as a duplicate of this bug. ***
Comment 2 User image Chris Peterson [:cpeterson] 2015-07-20 11:07:16 PDT
*** Bug 1173953 has been marked as a duplicate of this bug. ***
Comment 3 User image JackTail 2015-07-21 11:37:20 PDT
Tested with latest Nightly, works well with VOD but live streams stop after about 20 seconds.

Tests were done using the BitDASH player found at http://www.dash-player.com/demo/manifest-test/ with Wowza Streaming Engine as the CDN backend.
As well as other player in my own test environment.
Comment 4 User image Chris Peterson [:cpeterson] 2015-07-21 12:31:23 PDT
Thanks for testing, JackTail. Bitmovin's live stream demo gets stuck rebuffering for me, too:

http://www.dash-player.com/demo/live-streaming-dvr/

I filed bug 1186136 to track that issue.
Comment 5 User image JackTail 2015-07-21 13:36:11 PDT
Hope I am helping, new to submitting bugs like this.

My original testing was done using the DASH.js framework, https://github.com/Dash-Industry-Forum/dash.js/wiki
Self hosted works in Chrome and IE but not FireFox (Nightly build 42.0a1).

Hosted test players (of which, none work with live stream for me, even in Chrome) http://dashif.org/reference/players/javascript/index.html

Shows like it is about to play, but no video or audio. Does show time data from my Wowza server.

I would provide a test link, but streams on my server are not 24/7. Though I can set one up for demo if needed, the demo ones from Unified Streaming kind of work, but stop after 5 seconds in Chrome, no play at all in FireFox. I am not sure if this is only my end or not.
Comment 6 User image Jean-Yves Avenard [:jya] 2015-07-21 15:21:48 PDT
Are those live streams?

We have an issue with the DASH-IF player with live streams.

Though at this stage I haven't fully confirmed if the issue is on our hand, or its dash.js
Comment 7 User image Jean-Yves Avenard [:jya] 2015-07-30 18:31:53 PDT
Created attachment 8641401 [details] [diff] [review]
[MSE] P1. Remove whitelist.

We are now confident enough that MediaSource is usable by all
Comment 8 User image Matthew Gregan [:kinetik] 2015-07-30 18:38:49 PDT
Comment on attachment 8641401 [details] [diff] [review]
[MSE] P1. Remove whitelist.

Review of attachment 8641401 [details] [diff] [review]:
-----------------------------------------------------------------

\o/
Comment 11 User image Wes Kocher (:KWierso) 2015-07-31 17:12:41 PDT
https://hg.mozilla.org/mozilla-central/rev/135ffa347689
Comment 12 User image Florian Bender 2015-08-12 07:47:07 PDT
Release Note Request (optional, but appreciated)
[Why is this notable]: more HTML5 video for everyone
[Suggested wording]: Media Source Extension for HTML5 video enabled on all sites
[Links (documentation, blog post, etc)]:
Comment 13 User image Sylvestre Ledru [:sylvestre] 2015-10-02 03:06:50 PDT
Added to the release notes with "Media Source Extension for HTML5 video available for all sites" as wording.
I will update the item with a link to the docs when available.
Comment 14 User image Roque 2015-10-17 10:34:58 PDT
Will the remotion of the whitelist apply for Linux too?
Comment 15 User image Jean-Yves Avenard [:jya] 2015-10-17 15:12:29 PDT
There is no whitelist in 42 regardless of the platform. 
However, Linux in 42 only has support for MSE with webm. 
MSE with MP4 is enabled in 43 only
Comment 16 User image Roque 2015-10-18 17:30:41 PDT
Thanks.
Comment 17 User image Roque 2015-11-05 09:25:21 PST
Do you know why MSE is still not enabled in Linux? Youtube.com/html5 says so...
Comment 18 User image Chris Peterson [:cpeterson] 2015-11-05 10:27:25 PST
Roque, MSE should be enabled on Linux. youtube.com/html5 should show that "Media Source Extensions" and "MSE & WebM VP9" are enabled, but not necessarily "MSE & H.264".

If they are not, please file a new bug report including your browser's about:support troubleshooting information. Instructions are available here: https://support.mozilla.org/kb/use-troubleshooting-information-page-fix-firefox
Comment 19 User image Roque 2015-11-05 18:34:46 PST
Chris, MSE and MSE & WEbM VP9 aren't enabled, I tried it in another computer with Ubuntu and its the same... Should I report?
Comment 20 User image Chris Peterson [:cpeterson] 2015-11-05 20:47:24 PST
(In reply to Roque from comment #19)
> Chris, MSE and MSE & WEbM VP9 aren't enabled, I tried it in another computer
> with Ubuntu and its the same... Should I report?

If you are using Firefox 42 or later, please file a bug report. WebM VP9 should have been enabled on Linux in Firefox 42 by bug 1190970. In the bug report, please post your browser's about:support information, as described in this KB article:

https://support.mozilla.org/kb/use-troubleshooting-information-page-fix-firefox

Thanks!
Comment 21 User image Jean-Yves Avenard [:jya] 2015-11-06 01:40:43 PST
(In reply to Chris Peterson [:cpeterson] from comment #18)
> Roque, MSE should be enabled on Linux. youtube.com/html5 should show that
> "Media Source Extensions" and "MSE & WebM VP9" are enabled, but not
> necessarily "MSE & H.264".
> 
> If they are not, please file a new bug report including your browser's
> about:support troubleshooting information. Instructions are available here:
> https://support.mozilla.org/kb/use-troubleshooting-information-page-fix-
> firefox

MSE is only enabled in 43 beta on Linux.
Both MP4 and webm
Comment 22 User image Jean-Yves Avenard [:jya] 2015-11-06 01:41:50 PST
In 42; for now set media.mediasource.enabled = true and media.mediasource.webm = true
Comment 23 User image Chris Peterson [:cpeterson] 2015-11-06 10:13:24 PST
Jean-Yves is correct. I saw that MSE had been uplifted to Aurora 42 in bug 1190970 comment 37, but I did not see that it was later disabled by bug 1200834.
Comment 24 User image Roque 2015-11-06 10:20:32 PST
Thank you Jean-Yves and Chris Peterson. If i set those two values to true, will I have any issue when updating to 43?
Comment 25 User image Chris Peterson [:cpeterson] 2015-11-06 10:36:33 PST
(In reply to Roque from comment #24)
> Thank you Jean-Yves and Chris Peterson. If i set those two values to true,
> will I have any issue when updating to 43?

You should have no problems updating to 43.
Comment 26 User image Jean-Yves Avenard [:jya] 2015-11-06 13:27:20 PST
Just use beta now :)
Comment 27 User image Roque 2015-11-12 10:03:48 PST
Thanks.
Comment 28 User image Roque 2015-12-09 11:27:15 PST
Do you know if 43 on Linux is still having enabled Webm and MP4? Thanks.
Comment 29 User image Chris Peterson [:cpeterson] 2015-12-09 12:52:23 PST
(In reply to Roque from comment #28)
> Do you know if 43 on Linux is still having enabled Webm and MP4? Thanks.

Yes. Firefox 43 on Linux will support MSE with WebM and, if you have ffmpeg installed, also MP4.
Comment 30 User image Roque 2015-12-09 14:30:24 PST
Thanks Chris, great news, I have ubuntu 14.04, I think it has ffmpeg installed by default.
Comment 31 User image Masatoshi Kimura [:emk] 2016-02-07 16:46:37 PST
Did you find this bug in the regression range? MSE was enabled on YouTube even before this bug.
Comment 32 User image Jean-Yves Avenard [:jya] 2016-02-07 16:48:49 PST
Very unlikely this bug caused the regression seeing that YouTube was *never* impacted by the whitelist: in fact this bug was to allow other sites than YouTube to use MSE.
Comment 33 User image Virtual_ManPL [:Virtual] - (ni? me) 2016-02-08 11:02:37 PST
Yes. Looks like it's other issue.

Note You need to log in before you can comment on or make changes to this bug.