Status

()

RESOLVED DUPLICATE of bug 1178320
3 years ago
3 years ago

People

(Reporter: bnicholson, Assigned: sleroux)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
testAboutHomeDisposed is failing, meaning we have a memory leak somewhere.
tracking-fxios: ? → +
(Assignee)

Updated

3 years ago
Assignee: nobody → sleroux
(Assignee)

Comment 1

3 years ago
First of all, I guess when I switched out the root view controller from BVC to a UINavigationController, it messed up the tests. I added a quick patch for that: https://github.com/mozilla/firefox-ios/commit/42dab0cc75658fb4dd4a7da365dab7cbee42f3e9

Something strange is going on though - when I run the test, aboutHomeController doesn't get nil'ed out but when I run the app and put a breakpoint in the deinit method for HomePanelViewController, it gets called everytime which indicates that it is indeed getting released. Any idea on why it would not be nil'ing it out in the test case but does get nil'ed out when the app is run? Was wondering if you've seen this before with KIF.
Flags: needinfo?(bnicholson)
(Reporter)

Comment 2

3 years ago
Haven't seen this before, unfortunately. I'm pretty sure these tests were passing previously, though...I wonder if we'd be able to use git bisection to figure out which change broke them?
Flags: needinfo?(bnicholson)
tracking-fxios: + → ---
Component: General → Build & Test
Still failing?

Comment 4

3 years ago
I fixed the failing ViewMemoryLeakTests when working on bug 1178320 (see [1] & [2]). Sorry, I didn't know there was a duplicate bug. I was able to work around the missing nilification by using an explicit autorelease pool. It appears to be a bug in KIF since it does not happen when deriving from XCTestCase. I reported a bug upstream (see [3]).

Stephan, maybe you could give my pull request another review (or close it in favor of your branch).

[1] https://bugzilla.mozilla.org/show_bug.cgi?id=1178320
[2] https://github.com/mozilla/firefox-ios/pull/1229
[3] https://github.com/kif-framework/KIF/issues/739
Flags: needinfo?(sleroux)
(Assignee)

Comment 5

3 years ago
This is awesome! Thanks for fixing this bug - it was bother me for quite some time. I'll go ahead and mark this bug as a dupe of the other one. I looked over the PR and it looks good.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(sleroux)
Resolution: --- → DUPLICATE
Duplicate of bug: 1178320
You need to log in before you can comment on or make changes to this bug.