Closed Bug 1186617 Opened 6 years ago Closed 5 years ago

releng changes to decommission pandas

Categories

(Infrastructure & Operations Graveyard :: CIDuty, task)

task
Not set
normal

Tracking

(firefox48 fixed)

RESOLVED FIXED
Tracking Status
firefox48 --- fixed

People

(Reporter: kmoir, Assigned: kmoir)

References

Details

Attachments

(7 files, 5 obsolete files)

293.21 KB, patch
coop
: review+
kmoir
: checked-in+
Details | Diff | Splinter Review
1.70 KB, patch
aselagea
: review+
kmoir
: checked-in+
Details | Diff | Splinter Review
707.45 KB, patch
coop
: review+
kmoir
: checked-in+
Details | Diff | Splinter Review
55.56 KB, patch
jmaher
: review+
kmoir
: checked-in+
Details | Diff | Splinter Review
289.81 KB, patch
kmoir
: checked-in+
Details | Diff | Splinter Review
57.95 KB, patch
dustin
: review+
kmoir
: checked-in+
Details | Diff | Splinter Review
716 bytes, patch
kmoir
: checked-in+
Details | Diff | Splinter Review
remove platform buildbot-configs, buildbotcustom, devices.json in tools, slave health etc.
Blocks: 1186615
Assignee: nobody → kmoir
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1245585
actually I will use this bug to remove dead panda code
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Depends on: 1255471
Depends on: 1255528
Depends on: 1255530
Depends on: 1255532
patches to remove references to pandas, foopies, bmm and mozpool from tools repo
Attached patch bug1186617puppet.patch (obsolete) — Splinter Review
Attached patch bug1186617bbcustom.patch (obsolete) — Splinter Review
Attached patch bug1186617bbcustom.patch (obsolete) — Splinter Review
Attachment #8729115 - Attachment is obsolete: true
Attachment #8729116 - Attachment is obsolete: true
Attachment #8729131 - Flags: review?(coop)
remove mh scripts on inbound for panda and panda talos
Attachment #8729155 - Flags: review?(jmaher)
Comment on attachment 8729155 [details] [diff] [review]
bug1186617mh.patch

Review of attachment 8729155 [details] [diff] [review]:
-----------------------------------------------------------------

so beautiful!
Attachment #8729155 - Flags: review?(jmaher) → review+
Attachment #8729155 - Flags: checked-in+
Attachment #8729121 - Flags: review?(alin.selagea)
I removed the pandas and bm89 and 100-102 from the slavealloc databases too
Attachment #8729121 - Flags: review?(alin.selagea) → review+
Attachment #8729121 - Flags: checked-in+
https://hg.mozilla.org/mozilla-central/rev/d83f22ef3d5c
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Comment on attachment 8729131 [details] [diff] [review]
bug1186617sh.patch

Review of attachment 8729131 [details] [diff] [review]:
-----------------------------------------------------------------

We'll want to watch when this lands that it doesn't break on historical panda data in the db. Problems should appear as unknown entries on the index page.
Attachment #8729131 - Flags: review?(coop) → review+
Streamlining our reconfig process a bit now that foopies are no more.
Attachment #8729623 - Flags: review?(kmoir)
Comment on attachment 8729623 [details] [diff] [review]
[tools] Remove foopies from end-to-end reconfig script

Thanks!

I actually included this in https://bug1186617.bmoattachments.org/attachment.cgi?id=8729107 yesterday but didn't ask for review yet
Attachment #8729623 - Flags: review?(kmoir) → review+
Comment on attachment 8729623 [details] [diff] [review]
[tools] Remove foopies from end-to-end reconfig script

(In reply to Kim Moir [:kmoir] from comment #17) 
> I actually included this in
> https://bug1186617.bmoattachments.org/attachment.cgi?id=8729107 yesterday
> but didn't ask for review yet

OK, let's go with your more complete patch. Let me know when you want review.
Attachment #8729623 - Attachment is obsolete: true
Attachment #8729107 - Flags: review?(coop)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment on attachment 8729107 [details] [diff] [review]
bug1186617tools.patch

Review of attachment 8729107 [details] [diff] [review]:
-----------------------------------------------------------------

Can I get you to tag the tools repo *before* you land this patch with PANDA_FOOPY_SUTLIB (or something better, naming things is hard) so we can easily find this code again in the future if we need to?

Nit: you have trailing whitespace on some of your patched files. Might want to add something like https://github.com/ccooper/dotfiles/blob/master/.vimrc#L56 to your .vimrc file.
Attachment #8729107 - Flags: review?(coop) → review+
Attached patch bug1186617tools-2.patch (obsolete) — Splinter Review
patch with whitespace fixed
tagged as PANDA_FOOPY_SUTLIB_20160314 before landing patch
Attachment #8730204 - Attachment is obsolete: true
Attachment #8730212 - Flags: checked-in+
I ran a machine in staging against this patched puppet env and it worked fine.
Attachment #8729108 - Attachment is obsolete: true
Attachment #8730320 - Flags: review?(dustin)
Comment on attachment 8730320 [details] [diff] [review]
bug1186617puppet.patch

Review of attachment 8730320 [details] [diff] [review]:
-----------------------------------------------------------------

What a sea of `-`.. I love it

The /data/bmm directory should also be deleted (maybe check with Jake to see if we should back it up somewhere first), and the mozpool-related secrets removed, too.

::: modules/slaveapi/manifests/instance.pp
@@ -63,5 @@
>                  "furl==0.3.5",
>                  "orderedmultidict==0.7.1",
>                  "pytz==2013.7",
>                  "slaveapi==${version}",
> -                "mozpoolclient==0.1.5",

Does slaveapi need to be updated first?  Without mozpoolclient, will we get ImportErrors?
Attachment #8730320 - Flags: review?(dustin) → review+
dividehex: should the /data/bmm directory be backed up before we delete it?
Flags: needinfo?(jwatkins)
Comment on attachment 8729131 [details] [diff] [review]
bug1186617sh.patch

due to bug 1256375
Attachment #8729131 - Flags: checked-in-
Attachment #8729131 - Flags: checked-in- → checked-in+
Depends on: 1256375
changes to slave api to remove mozpoollclient are in bug 1256375
(In reply to Kim Moir [:kmoir] from comment #25)
> dividehex: should the /data/bmm directory be backed up before we delete it?

Well, I don't ever see this project being resurrected from the dead but just for nostalgia I've taken a tarball of bmm.  You can go ahead and remove it from /data
Flags: needinfo?(jwatkins)
Attachment #8730320 - Flags: checked-in+
Attachment #8729107 - Flags: checked-in+
closing - I think I have removed all the panda code.
Status: REOPENED → RESOLVED
Closed: 6 years ago5 years ago
Resolution: --- → FIXED
fix slave_health crontab to not copy devices.json
Comment on attachment 8732351 [details] [diff] [review]
bug1186617sh-2.patch

and updated slave_health on cruncher manually and now the worker health web page is updating again
Attachment #8732351 - Flags: checked-in+
Component: Platform Support → Buildduty
Product: Release Engineering → Infrastructure & Operations
Product: Infrastructure & Operations → Infrastructure & Operations Graveyard
You need to log in before you can comment on or make changes to this bug.