Right click in map area leads to illegal memory access

VERIFIED DUPLICATE of bug 114377

Status

VERIFIED DUPLICATE of bug 114377
17 years ago
14 years ago

People

(Reporter: peterthaus, Assigned: asa)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Right clicking in an area with mapped-links makes mozilla crash with an illegal
memory access.

The following HTML-code was taken (and shorted) from http://www.kempten.de.
Click on the text "Erweiterte Suche" in the picture (all other links had been
removed) with the right mouse button and mozilla will end with a system error
(badly translated from German):
The operation in "0x6026d979" points to a memory in "0x00000018". Read could not
be executed on memory.
It seems to be the same memory address every time.
Okay, here is the code:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">

<html>
<head>
  <title>index / Stadt Kempten </title>
  <META http-equiv="Content-Type" content="text/html; charset=iso-8559-1">
</head>

<BODY>
  <TABLE WIDTH=679 BORDER=0 CELLSPACING=0 CELLPADDING=0>
    <TR>
      <TD><IMG ID="Picture3" HEIGHT=84 WIDTH=679 SRC="header_1.gif" BORDER=0
USEMAP="#map3"><MAP NAME="map3">
        <AREA SHAPE=RECT ALT="Erweiterte Suche" COORDS="143,33,253,50"   
HREF="http://www.kempten.de/suche.html">
      </MAP></TD>
    </TR>
  </TABLE>
</BODY>
</HTML>

Comment 1

17 years ago
I am able to bring up a context menu on Mac debug build from today (with no
crash)--either click-hold or control click invocation works fine.

What is the build ID which exhibits this bug?

Comment 2

17 years ago
dup of a recently fixed top-crasher


*** This bug has been marked as a duplicate of 114377 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
verify dupe; reporter told me he was using an older build (2001122106 running on
Windows 2000 with SP2)
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.