Auto-capitalise the first word in the summary when filing a bug

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: gkw, Unassigned)

Tracking

({foxfood})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
We should auto-capitalise the first word in the summary when filing a bug. Note that I found bug 804587 when checking for dupes - not sure if it's related.
Hrm, I tried x-inputmode="latin-prose" and couldnt get this working, any ideas David?
Flags: needinfo?(dflanagan)
In the uitest app, in the UI/keyboard test, <input type="text" x-inputmode="latin-prose"> does correctly autocapitalize at the start and at the beginning of new sentences. If you're using a textarea, you should get this behavior by default. The UI tests also seem to show that this is the default for contenteditable and designmode=on editable text.

Also: I can't reproduce the bug. I'm running gecko from November 5th, and just flashed today's gaia to my Aries. Text input in both the summary and description have autocapitalization on. 

Dale, what are your STR for reproducing this? What keyboard languages do you have installed? Did you install an alternate keyboard?  Did you modify any of the settings? If you turn off autocorrection and word suggestions maybe that break autocapitalization?
Flags: needinfo?(dflanagan) → needinfo?(dale)
So I accidentally committed x-inputmode to master and you are right it is working, I may have been testing in a cached version or the wrong staging.

Fixed in https://github.com/mozilla-b2g/bzlite/commit/4b7b70d151ebad6252350da8cce0d3c9f55a9fba
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(dale)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.