[Keyboard] Do not capitalise the first letter for input type=text by default

VERIFIED FIXED

Status

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: benfrancis, Assigned: djf)

Tracking

unspecified

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Reporter)

Description

6 years ago
STR:
* Open browser app
* Focus awesomebar

Expected:
* First letter not capitalised

Actual:
* First letter capitalised

Alternative STR:
* Open UI Tests app
* Select Keyboard test
* Focus "input type=text" box

Expected:
* First letter is not capitalised

Actual:
* First letter is capitalised

I discussed this with Mounir and he feels the default behaviour should be that type=text does not capitalise, but type=textarea does.

If we want to do autocapitalisation for type=text we need to support that inputMode, as described bug 796544
(Reporter)

Comment 1

6 years ago
(Note that the STR for the browser app will not work until https://github.com/mozilla-b2g/gaia/pull/5955 lands)
(Assignee)

Comment 2

6 years ago
taking this and wrapping it into my big keyboard refactor.
Assignee: nobody → dflanagan
Blocks: 797155
(In reply to David Flanagan [:djf] from comment #2)
> taking this and wrapping it into my big keyboard refactor.

David, for information, the recommended workflow with bugzilla is to split patches because it is easier to review and more understandable. Having one patch to rule them all is usually not an ideal situation.
Duplicate of this bug: 804839
(Reporter)

Updated

6 years ago
blocking-basecamp: ? → +
Re-writing the summary. I think it's better to say what should be done instead of saying what is currently done.
Summary: [Keyboard] Capitalises first letter for input type=text by default → [Keyboard] Do not capitalise the first letter for input type=text by default
(Assignee)

Comment 7

6 years ago
Fixed by https://github.com/mozilla-b2g/gaia/pull/6007
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 8

6 years ago
verified
build info
2012-10-26
gaia master : 2c50025f7a7ce6f2e653c0e75ef7bd505d823cb8
gecko : c9173078c6a84ed9a423868090cf57f593247f53
Status: RESOLVED → VERIFIED

Updated

6 years ago
Component: Gaia → Gaia::Keyboard
You need to log in before you can comment on or make changes to this bug.