Default buttons have their borders and frames drawn twice on GTK3

RESOLVED FIXED in Firefox 42

Status

()

defect
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: acomminos, Assigned: acomminos)

Tracking

unspecified
mozilla42
Unspecified
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox42 fixed)

Details

Attachments

(1 attachment)

If a button is a default button and has a relief, its background and frame will be drawn twice (see moz_gtk_button_paint in gtk3drawing.c, note that case where state->isDefault and relief == GTK_RELIEF_NORMAL). This appears to be unintended, and is not done by upstream GTK's gtk_button_draw.
This should more accurately follow the upstream GTK implementation, and make default buttons look correct. Thanks!
Attachment #8639558 - Flags: review?(karlt)
Attachment #8639558 - Flags: review?(karlt) → review+
Blocks: 1187166
https://hg.mozilla.org/mozilla-central/rev/570c40c6fe4b
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
Duplicate of this bug: 1187166
Depends on: 1249604
No longer depends on: 1249604
You need to log in before you can comment on or make changes to this bug.