[Aries][Gallery] Wallpaper preview screen displays a small image.

VERIFIED FIXED in Firefox 42

Status

()

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: ddixon, Assigned: kats)

Tracking

({regression})

42 Branch
mozilla42
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(blocking-b2g:2.5+, firefox42 fixed, b2g-v2.2 unaffected, b2g-master verified)

Details

(Whiteboard: [2.5-Daily-Testing])

Attachments

(3 attachments, 1 obsolete attachment)

Description:
The Wallpaper preview screen in Gallery app displays a very small image.  
The image will appear in the upper left corner of the screen.  

Repro Steps:
1) Update a Aries to 20150727165113
2) Go to Gallery
3) Select an image and tap Share icon
4) Select "Wallpaper" to activate preview

Actual:
Wallpaper preview screen displays a small image. 

Expected:
Wallpaper preview screen displays image at the correct size (full screen). 

Notes: The repro frequency may vary from image to image. 

Environmental Variables:
Device: Aries 2.5
Build ID: 20150727165113
Gaia: 302a448729ff2b336581cf94b66327ea836294c7
Gecko: d576f2cec511
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Repro frequency: 8/10 

Video:
http://youtu.be/foS_qnoRBOs
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Whiteboard: [2.5-Daily-Testing]
Branch Check

Issue DOES occur on Flame 2.5

Device: Flame 2.5
BuildID: 20150728072944
Gaia: a8319543833b08e986fa3ed590faeb2624bf1683
Gecko: bc589dd18ad5
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 42.0a1 (2.5) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
------------------------------------------
------------------------------------------
Issue DOES NOT occur on Flame 2.2, 2.1

Device: Flame 2.2
Build ID: 20150728032504
Gaia: e1e6317f17a840b19af9dbb25f5a771d8d9fa161
Gecko: 9b60e57724db
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
------------------------------------------
Device: Flame 2.1
BuildID: 20150723133047
Gaia: 9dba58d18006e921546cec62c76074ce81e16518
Gecko: 41e10c6740be
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
[Blocking Requested - why for this release]:

Regression of a basic functionality so nominating this 2.5?
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Mozilla-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame KK 2.5
Build ID               20150721075041
Gaia Revision          4fe0507781f3ed56c8ae5e66dd9489165d1ff68e
Gaia Date              2015-07-20 16:09:12
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/49ae0961591e
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150721.044756
Firmware Date          Tue Jul 21 04:48:08 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Environmental Variables:
Device: Flame KK 2.5
Build ID               20150721075241
Gaia Revision          4fe0507781f3ed56c8ae5e66dd9489165d1ff68e
Gaia Date              2015-07-20 16:09:12
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/fee45cd9a4d9
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150721.044756
Firmware Date          Tue Jul 21 04:48:08 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Gaia & Last Working Gecko - issue DOES NOT repro:
Gaia Revision          4fe0507781f3ed56c8ae5e66dd9489165d1ff68e
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/49ae0961591e

First Broken Gecko & Last Working Gaia – issue DOES repro:
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/fee45cd9a4d9
Gaia Revision          4fe0507781f3ed56c8ae5e66dd9489165d1ff68e

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=49ae0961591e&tochange=fee45cd9a4d9

Possibly caused by bug 1178847.
Regression, blocking

Thanks
Hema
Assignee: nobody → pdahiya
blocking-b2g: 2.5? → 2.5+
QA Whiteboard: [MGSEI-Triage+]
Debugged and the issue is incorrect window.innerWidth and window.innerHeight returned on Aries and Flame. windowWidth and windowHeight is used to compute scale to display previewImage at width that fits the screen.

https://github.com/mozilla-b2g/gaia/blob/master/apps/wallpaper/js/share.js#L102

For Aries window.innerWidth and window.innerHeight that results in this bug is 132 x 217 instead of 360 x 590

For Flame window.innerWidth and window.innerHeight returned is 104 x 186 instead of 320 x 569

As noted in #comment 3, the incorrect window.innerWidth and window.innerHeight could be regression because of bug 1178847. Setting NI flag for Kartikaya for his inputs on this issue. Thanks
Flags: needinfo?(bugmail.mozilla)
Thanks for the investigation. I landed a fix recently (bug 1187056) which may fix this, but I'm not 100% sure. I'll take this bug off your hands for now, and investigate it in the next few days when I get a chance.
Assignee: pdahiya → bugmail.mozilla
Flags: needinfo?(bugmail.mozilla)
Posted file Log of MVM
So bug 1187056 didn't fix this, and I can reproduce this pretty easily. I'm attaching a log of what's going on. On initial load the CSS viewport is set to width=980, and then a meta-viewport tag comes in. This changes the CSS viewport to width=360, and adjusts the resolution to 2.72. It also sets the SPCSPS to w=132, and that's what window.innerWidth returns to the JS code in the wallpaper app. During the first-paint, the resolution and SPCSPS get reset but the transient bad value that it had is what gets used for the image size computation.

I think what we want to do here is not update the resolution properties if the DOMMetaAdded came in before the first-paint, because the first-paint is going to reset everything anyway and there's no point in having this transient value exposed to JS.
Component: Gaia::Gallery → Layout
Product: Firefox OS → Core
Version: unspecified → 42 Branch
Posted patch Patch (obsolete) — Splinter Review
Attachment #8642113 - Flags: review?(botond)
Posted patch PatchSplinter Review
Whoops, that was the wrong file. Here's the correct one. Try push at https://treeherder.mozilla.org/#/jobs?repo=try&revision=2c38a45bfe6a
Attachment #8642113 - Attachment is obsolete: true
Attachment #8642113 - Flags: review?(botond)
Attachment #8642114 - Flags: review?(botond)
Comment on attachment 8642114 [details] [diff] [review]
Patch

Review of attachment 8642114 [details] [diff] [review]:
-----------------------------------------------------------------

I guess this is the sort of problem that we couldn't think of back in bug 1178847 :)

> > > Yes, that can happen. For example if there is a meta-viewport tag that gets
> > > processed before the first paint (which is actually quite often) then we get
> > > a viewport computation while mIsFirstPaint=false.
> > 
> > I guess I was asking if that would be a problem, but I can't think of any
> > reason why it would be.
> 
> Yeah, I don't think it should be a problem either.
Attachment #8642114 - Flags: review?(botond) → review+
(In reply to Botond Ballo [:botond] from comment #10)
> I guess this is the sort of problem that we couldn't think of back in bug
> 1178847 :)
> 

Indeed :)
https://hg.mozilla.org/mozilla-central/rev/838a7d98c1d4
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
This issue is verified fixed on Aries and on Flame. Following STR, wallpaper preview is displayed correctly. Bug repro rate: 0 out of 30 attempts.

Device: Aries 2.5
BuildID: 20150804120650
Gaia: 67c38af8347f93ddc005a53f427d651b744b55c1
Gecko: 5cf4d2f7f2f2
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Device: Flame 2.5
BuildID: 20150804030213
Gaia: caba8b26c52d3c771e9ea6fe288acdaf74c7707e
Gecko: 5b54831761b1
Gonk: 41d3e221039d1c4486fc13ff26793a7a39226423
Version: 42.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+] → [MGSEI-Triage+], [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [MGSEI-Triage+], [QAnalyst-Triage?] → [MGSEI-Triage+], [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Duplicate of this bug: 1190666
You need to log in before you can comment on or make changes to this bug.